GPS coordinates incorrect and accuracy very bad since 1.1

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
9 months ago

People

(Reporter: dev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0 (Beta/Release)
Build ID: 20130625102402

Steps to reproduce:

Device: Geeksphone Peak
Version: 1.1.0.0hd-prerelease
BuildId: 20130730003747

Start the HERE maps application or the GPS dashboard application


Actual results:

GPS position is detected immediately but it says I live near Dijon while I live in Paris (HERE maps) and the GPS accuracy value is 325239m (both GPS dashboard and the size of the dot on HERE maps).
Waiting 3-5 minutes standing still under clear sky doesn't improve the GPS situation and accuracy. 


Expected results:

Correct GPS position and accuracy should have been computed at least after having stood still under clear sky.
(Reporter)

Comment 1

5 years ago
On a sidenote, in previous 1.0.x version, GPS sync was never immediate, but always worked after standing still for 3-5 minutes.
(Reporter)

Comment 2

5 years ago
With the following version:

Version: 1.1.0hd-prerelease
Build id: 20130807112252

GPS behavior is back to 1.0.x behavior: GPS sync requires standing still a few minutes but works.

Comment 3

5 years ago
I have the same problem, I have a Geeksphone Keon with version 1.1.0.0-prerelease and I am developing application with geolocation well as in Here Maps, Google Maps I located 800km from my current location, too!

As I have gotten a ZTE Open with version 1.0.1.0-prerelease and this device is not even placing, leave the apps open for more than 5 minutes and never returns anything.

In fact for this reason we have problems uploading our app to the Marketplace.

Comment 4

5 years ago
Same here.
I think this might be a duplicate of bug 892057?

Comment 6

5 years ago
European (UK) ZTE Open. Since 1.1 GPS accuracy at least 2 miles out.

Comment 7

5 years ago
ZTE Open v1.3 no gps at all.

Updated

4 years ago
Duplicate of this bug: 940828

Comment 9

9 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.