Defect - Progress bar not showing up for content link clicks

RESOLVED FIXED in Firefox 26

Status

P2
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: jimm, Assigned: mbrubeck)

Tracking

({regression})

Trunk
Firefox 26
x86_64
Windows 8.1
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=defect c=main_ui_reorganization u=metro_firefox_user p=1)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
STR:

navigate via a link in a page
result: no progress bar

really recent regression
(Reporter)

Updated

6 years ago
Summary: Progress bar now showing up for content link clicks → Progress bar not showing up for content link clicks
Summary: Progress bar not showing up for content link clicks → Defect - Progress bar not showing up for content link clicks
Whiteboard: feature=defect c=tbd u=tbd p=0
(Reporter)

Comment 1

6 years ago
I'm not seeing the nav bar either, which might be the core issue. Need to go back a couple days and see how this used to work.
(Reporter)

Comment 3

6 years ago
I can confirm that _progressStart is getting called on link navs - 

http://mxr.mozilla.org/mozilla-central/source/browser/metro/base/content/WebProgress.js#176

so maybe this is in css somewhere.
(Assignee)

Comment 4

6 years ago
Looks like this is a regression from the change in bug 899726 that set "visibility: hidden" on off-screen <appbar> elements.
Blocks: 899726
Keywords: regression
(Assignee)

Comment 5

6 years ago
Taking this for this iteration; work estimate p=1.
Whiteboard: feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=1
(Assignee)

Comment 6

6 years ago
Posted patch patch v2Splinter Review
This seems reasonable, but I'm curious if anyone can think of a simpler way to do this.  I tried moving the #progress-container out of the #navbar, but that makes it hard to get the right layout.
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attachment #785878 - Flags: review?(sfoster)
Blocks: 893311
No longer blocks: 859003
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: feature=defect c=tbd u=tbd p=1 → feature=defect c=main_ui_reorganization u=metro_firefox_user p=1
Blocks: 845152
Comment on attachment 785878 [details] [diff] [review]
patch v2

Review of attachment 785878 [details] [diff] [review]:
-----------------------------------------------------------------

I played with this a bit too. To move the progressbar out of the appbar#navbar, we would need to track the height of the appbar to position it above. bottom: calc(@toolbar_height@ + @toolbar_vertical_spacing@); works when its showing, but there's no way currently to construct a rule for when it is not showing. And then we would also run into problems with the transitions. So this seems like the way to go. 

It kind of bugs me that the navbar container is actually just a group of stuff at the bottom of the screen that doesn't have much to do with navigation. Meh, we can fix that when a better name is suggested.
Attachment #785878 - Flags: review?(sfoster) → review+
https://hg.mozilla.org/mozilla-central/rev/7558a07a7ed6
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Went through the following "Defect" for iteration #12 without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-08-20-03-02-06-mozilla-central/

- Went through the original test case from comment #0 without any issues
- Tapped on at least 20-30 links while browsing through Wikipedia and ensured that the progress bar appeared without any issues
- Ensured that the progress bar appears correctly when going through context menu's (tapping and holding links and then selecting "Open link in new tab")
- Ensured that tapping on the "Forwards" & "Backwards" buttons on the Navigation App Bar also showed the progress bar without any issues
- Ensured that selecting "Refresh" on the Navigation App Bar showed the progress bar without any issues
- Ensured that going navigating using URL's in the Navigation App Bar showed the progress bar without any issues
- Also went through all of the above test cases in filled view without issues
Went through the following "Defect" for iteration #13 without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-08-31-03-02-24-mozilla-central/

- Went through the original issue from comment #0 without any issues
- Went through the test cases added in comment #10 without any issues
Went through the following "Defect" for iteration #13 without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-09-18-03-02-02-mozilla-central/

- Went through the original issue from comment #0 without any issues
- Went through the test cases added in comment #10 without any issues
meant iteration #14 for the above comment!
Went through the following "Defect" for iteration #16 without issues. Used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-10-23-03-02-05-mozilla-central/

- Went through the original issue from comment #0 without any issues
- Went through the test cases added in comment #10 without any issues
- Used the "Back" overlay button and ensured that the progress bar appears correctly every single time
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.