If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Helix][Dialer] A call which required keyboard or voice input during the call will be terminated after input is given

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: swaroopa, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:hd+)

Details

(Whiteboard: [POVB])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 785208 [details]
Log cat

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/f0e9fcb591c2
Gaia   64f48c2cebddbbfb2bdeb93a88b3c6817f45736a
BuildID 20130802072203
Version 18.0

STR:
1. Make a call to a customer care (Example a wells fargo customer care#: 800-956-4442)
2. Once call is connected it would ask for a key board or voice input for the account number
3. Provide the the details through voice or by entering the account number through dialer key board(I gave an invalid number)

Actual Result:
Either the call disconnects immediately after I enter the number OR
after entering the number a customer care voice says its invalid. Before it completes the message the call is disconnected.

Expected Result:
The call should not disconnect after the user provides the required input during the call.
Component: Gaia::Dialer → Vendcom
Shawn, maybe you can take a look at this?
blocking-b2g: hd? → hd+
Flags: needinfo?(sku)

Comment 2

4 years ago
Hi Swaroopa:
 We can not find any RIL log in attachment.
Please kindly follow below steps to enable RIL log, then, capture the log for us again.

Many thanks!!

1. make sure RIL debug configuration is enabled.
   1.1 adb pull /system/b2g/defaults/pref/user.js /tmp
   1.2 Modify the value of ril.debugging.enabled to true.
       pref("ril.debugging.enabled", true);
   1.3 adb remount
   1.3 adb push /tmp/user.js /system/b2g/defaults/pref/
   1.4 adb reboot
Flags: needinfo?(sku) → needinfo?(svantipalli)
(Reporter)

Comment 3

4 years ago
Created attachment 787714 [details]
adblogcat_ril.txt

Attached the log cat of the issue with RIL enabled. Please check if it helps.
Flags: needinfo?(svantipalli)

Updated

4 years ago
Flags: needinfo?(sku)

Comment 4

4 years ago
This should be network(remote) end call behavior.
and, modem/network did not specify the cause of this disconnect.

We will claim this as network issue.

// remote end call w/o cause.
08-08 12:03:02.239: I/Gecko(157): -*- RILContentHelper: Received message 'RIL:CallError': {"state":0,"callIndex":1,"toa":129,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"8009564442","numberPresentation":0,"name":"","namePresentation":0,"uusInfo":null,"isOutgoing":true,"isEmergency":false,"started":1375988536229,"rilRequestType":18,"rilRequestError":0,"rilMessageType":"callError","errorMsg":"UnspecifiedError"}

Note:
the reference phone should have the same behavior on connected to 8009564442, and, sending a bunch of DTMF requests.


08-08 12:02:16.209: I/Gecko(157): RIL Worker: Handling parcel as UNSOLICITED_RESPONSE_CALL_STATE_CHANGED
08-08 12:02:16.219: I/Gecko(157): RIL Worker: Handling parcel as REQUEST_GET_CURRENT_CALLS
08-08 12:02:16.229: I/Gecko(157): -*- RadioInterfaceLayer: Received message from worker: {"rilMessageType":"callStateChange","call":{"state":0,"callIndex":1,"toa":129,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"8009564442","numberPresentation":0,"name":"","namePresentation":0,"uusInfo":null,"isOutgoing":true,"isEmergency":false,"started":1375988536229}}
08-08 12:02:43.149: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"1"}
08-08 12:02:43.589: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"2"}
08-08 12:02:44.169: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"3"}
08-08 12:02:44.609: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"5"}
08-08 12:02:44.969: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"4"}
08-08 12:02:45.349: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"7"}
08-08 12:02:45.749: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"8"}
08-08 12:02:46.119: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"6"}
08-08 12:02:46.479: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"1"}
08-08 12:02:46.889: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"2"}
08-08 12:02:47.219: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"8"}
08-08 12:02:47.629: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"#"}
08-08 12:03:01.579: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"1"}
08-08 12:03:01.659: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"stopTone"}
08-08 12:03:01.979: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"stopTone"}
// Modem report call state change
08-08 12:03:02.099: I/Gecko(157): RIL Worker: Handling parcel as UNSOLICITED_RESPONSE_CALL_STATE_CHANGED
// query current call list
08-08 12:03:02.119: I/Gecko(157): RIL Worker: Handling parcel as REQUEST_GET_CURRENT_CALLS
// got empty list, query call fail cause
08-08 12:03:02.149: I/Gecko(157): RIL Worker: Handling parcel as REQUEST_LAST_CALL_FAIL_CAUSE
// remote end call w/o cause.
08-08 12:03:02.239: I/Gecko(157): -*- RILContentHelper: Received message 'RIL:CallError': {"state":0,"callIndex":1,"toa":129,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"8009564442","numberPresentation":0,"name":"","namePresentation":0,"uusInfo":null,"isOutgoing":true,"isEmergency":false,"started":1375988536229,"rilRequestType":18,"rilRequestError":0,"rilMessageType":"callError","errorMsg":"UnspecifiedError"}

08-08 12:03:02.269: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"2"}
08-08 12:03:02.739: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"5"}
08-08 12:03:03.159: I/Gecko(157): RIL Worker: Received DOM message {"rilMessageType":"startTone","dtmfChar":"8"}
Flags: needinfo?(sku)
Swaroopa, can you test the same behaviour with the same SIM on a different phone?

Per comment 4, the call seems to disconnected by the network.
Flags: needinfo?(svantipalli)
(Reporter)

Comment 6

4 years ago
Created attachment 789010 [details]
adblogcat_ril_LEO.txt

The tried the STR on Leo with the same SIM. 
The issue is not reproducible. The call was on until I manually disconnected.

Attached the Log for leo
Flags: needinfo?(svantipalli)

Comment 7

4 years ago
the new log shows that the call was disconnected by user request.

@Wayne:
Please invite Helix team to check QXDM if any.

08-12 09:27:38.838: I/Gecko(503): -*- RILContentHelper: Sending Tone for 9
08-12 09:27:39.518: I/Gecko(503): -*- RILContentHelper: Sending Tone for 5
08-12 09:27:39.728: I/Gecko(503): -*- RILContentHelper: Sending Tone for 4
08-12 09:27:40.188: I/Gecko(503): -*- RILContentHelper: Sending Tone for 4
08-12 09:27:40.898: I/Gecko(503): -*- RILContentHelper: Sending Tone for #
08-12 09:27:49.768: I/Gecko(503): -*- RILContentHelper: Sending Tone for 5
08-12 09:27:50.198: I/Gecko(503): -*- RILContentHelper: Sending Tone for 8
08-12 09:27:50.528: I/Gecko(503): -*- RILContentHelper: Sending Tone for 9
08-12 09:27:50.758: I/Gecko(503): -*- RILContentHelper: Sending Tone for 9
08-12 09:27:51.148: I/Gecko(503): -*- RILContentHelper: Sending Tone for 9
08-12 09:27:51.368: I/Gecko(503): -*- RILContentHelper: Sending Tone for 5
08-12 09:27:51.878: I/Gecko(503): -*- RILContentHelper: Sending Tone for 5
08-12 09:27:52.088: I/Gecko(503): -*- RILContentHelper: Sending Tone for 4
08-12 09:27:52.448: I/Gecko(503): -*- RILContentHelper: Sending Tone for 4
08-12 09:27:52.648: I/Gecko(503): -*- RILContentHelper: Sending Tone for 7
08-12 09:27:52.888: I/Gecko(503): -*- RILContentHelper: Sending Tone for 8
08-12 09:27:53.248: I/Gecko(503): -*- RILContentHelper: Sending Tone for #
08-12 09:28:35.918: I/Gecko(136): -*- QCContentHelper_QC_B2G: receiveMessage: 'RIL:HangUp' arrived from content process
08-12 09:28:36.248: I/Gecko(503): -*- RILContentHelper: Received message 'RIL:CallStateChanged': {"state":10,"callIndex":1,"toa":129,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"8009564442","numberPresentation":1,"name":null,"namePresentation":1,"uusInfo":null,"isActive":false,"isOutgoing":true,"isEmergency":false}
08-12 09:28:36.538: I/Gecko(136): -*- RILContentHelper: Received message 'RIL:CallStateChanged': {"state":10,"callIndex":1,"toa":129,"isMpty":false,"isMT":false,"als":0,"isVoice":true,"isVoicePrivacy":false,"number":"8009564442","numberPresentation":1,"name":null,"namePresentation":1,"uusInfo":null,"isActive":false,"isOutgoing":true,"isEmergency":false}
Flags: needinfo?(wchang)
Anshul, any pointers on how we should continue here?

This doesn't happen here in Taipei, seems to happen with the network that Swaroopa is testing on.

Helix - network seemingly disconnects us after sending DTMF
Leo - call continues after sending DTMF.
Flags: needinfo?(wchang) → needinfo?(anshulj)

Comment 9

4 years ago
Wayne, this does seem like a network issue.
Flags: needinfo?(anshulj)
Why would it happen only on Helix? Can Swaroopa provide you anything to check here?
Flags: needinfo?(anshulj)

Comment 11

4 years ago
Wayne, I am not sure. Please ask Helix customer to file an SR and we can follow up on the issue with them.
Flags: needinfo?(anshulj)

Updated

4 years ago
Component: Vendcom → General
Hi Lecky,

Please continue the investigation here via SR with QCT here. 
Given the available logs and comments, this seems to be not actionable on Mozilla's side. I am flagging this as POVB.
Flags: needinfo?(lecky.wanglei)
Whiteboard: [POVB]

Comment 13

4 years ago
HI zhaotao 
Please check this issue.
Flags: needinfo?(lecky.wanglei) → needinfo?(zhao_tao59)

Comment 14

4 years ago
hi,wayne

the issue was raised in August,

and we can not reproduce it on our phone.

So,can you internally check that if it still exist?
Flags: needinfo?(zhao_tao59)
Leck,
This only happens in the US.

John, do you know what network Swaroopa tested this on?
Flags: needinfo?(jhammink)

Comment 16

4 years ago
Hi,

She would have tested this on one of AT&T or TMobile.  

I tried it on AT&T and on the following build:
Gaia   922de46ad5e4a8b513b24233a7f3bc54b93e9612
SourceStamp 2664ac296982
BuildID 20131018004000
Version 26.0a2
And so far, have not reproduced it.
Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jhammink)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.