Deleting attachments sometimes deletes the message itself

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: bob, Unassigned)

Tracking

17 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

I delete some or all attachments in messages, and the message itself disappears entirely.  I'm very used to deleting attachments and keeping messages, but since the new version (17.0.7), the problem occurs.  Not all the time, and I can't offer any clue as to when it happens and when it doesn't.  It doesn't seem to matter where the message is (i.e., trash or other folder).  Problem happens often (maybe 50% of the time or more).  


Actual results:

The message disappears entirely when attachments are deleted (one or all attachments).


Expected results:

The message should remain with fewer or no attachments.

This type of bug was apparently reported and resolved a long time ago.  I've been using TB for years, but this problem is new and recent.

Thanks for looking into this.

Comment 1

5 years ago
an imap account?
and only started happening in version 17.0.7?
what happens if you go back to 17.0.6?
  available from https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/
Flags: needinfo?(bob)
(Reporter)

Comment 2

5 years ago
I can't specifically say for sure that it is tied to version 17.0.7.  I guess I could find and go back to the previous version if you like (point me in the right direction, please).  But it only started happening in the last two weeks.  That may tell you (by the version date which I don't have) whether it predates .0.7.  

Thanks for the response.

Bob
Flags: needinfo?(bob)

Comment 3

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #1)
> what happens if you go back to 17.0.6?
>   available from
> https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/

https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/17.0.6/
(Reporter)

Comment 4

5 years ago
Okay.  I installed 17.0.6.  Umm, the link you provided was not that helpful (got to the Win32 folder but couldn't fiture out how to proceed from there), but I found it at filehippo.  Verified that it is 17.0.6.  Sent myself five test messages and then deleted attachments from both the inbox and the sent box.  Everything worked normally, both deleting individual files and deleting all.  Now the problem had been intermittent so this isn't a guarantee.  But it seems to be a solid data point at present.

Thanks for your help here.  LMK if you need me to do more.
wild guess on causes:

- user error: perhaps after deleting attachments on 10+ messages, user forgot to focus attachments and then pressed DEL which ended up on message focus
- user error: perhaps msgs were (inadvertently?) sorted by size, removing attachments shrinks size -> msg will go down ("disappear") in the list sequence
- autocompact: any chance that autocompact can co-occur with attachment deletion and cause weird effects?

WADA, can you comment on last bit?
Summary: Deleting attachments deletes the message itself → Deleting attachments sometimes deletes the message itself
bob (reporter), please provide detailed step by step instructions how exactly you delete attachments. It might matter e.g. if you use DEL key on keyboard or Delete-Button, and which Delete-Button (on msg header, or on main toolbar). Include sort order of msg list and try to remember if you had the same sort order when it happened.

Then describe exactly what you see and how you verified that the message has been deleted (Actual Results).

is it a pop or imap account?
Flags: needinfo?(bob)
(Reporter)

Comment 7

5 years ago
(In reply to Thomas D. from comment #6)
> bob (reporter), please provide detailed step by step instructions how
> exactly you delete attachments. It might matter e.g. if you use DEL key on
> keyboard or Delete-Button, and which Delete-Button (on msg header, or on
> main toolbar). Include sort order of msg list and try to remember if you had
> the same sort order when it happened.
> 
> Then describe exactly what you see and how you verified that the message has
> been deleted (Actual Results).
> 
> is it a pop or imap account?

It's a pop account.

The "sort order" comment made me rethink the problem.  I may have deleted attachments to messages when messages were sorted by size.  The deletion changed the size of the file, and the message "disappeared".  At least, that is my current theory here.  I haven't gone back to 17.0.7 to test this, but I will do so soon.

I will report anew if I find a different cause or if the problem persists.  I apologize for the erroneous report, and I thank all for responding.  If I still have a problem, I will provide the requested step-by-step description.  In the meantime, maybe the right thing is to consider this closed.  Thanks again.
Flags: needinfo?(bob)
bob, thanks a lot for swift feedback, that's helpful!
So per reporter's comment 7, wfm until further notice :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.