Downloading a file returns a window with a XML error

VERIFIED DUPLICATE of bug 851217

Status

VERIFIED DUPLICATE of bug 851217
6 years ago
3 years ago

People

(Reporter: vkeranov, Unassigned)

Tracking

22 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 785357 [details]
The error window

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Using the latest Firefox (22.0), installing a Webapp and trying to download a file from the application (.doc, .pdf, .csv).


Actual results:

Instead of a download window, there is a window with a XML error. The error says something about a missing component "<description>&intro2.label;</description>".


Expected results:

The expected result is a window to choose where to save the file on my hard drive.
(Reporter)

Updated

6 years ago
Component: Untriaged → Webapp Runtime

Comment 1

6 years ago
Which webapp? Did you try with another browser?
Flags: needinfo?(vkeranov)
(Reporter)

Comment 2

6 years ago
I was asked to open this bug request, when I was searching for help on IRC, #openwebapps

I was testing with latest Firefox (22.0) both on Windows 7 and Windows XP. What do you mean by "another" browser? You can simply create a test webapp, with a simple manifest file. And then add a link to a file like:
<a href="/path/to/example_file.doc">test to download</a>
And then you'll see the error message.
Flags: needinfo?(vkeranov)

Comment 3

6 years ago
So could you attach such a testcase as webapp. It would help to test.
Flags: needinfo?(vkeranov)
(Reporter)

Comment 4

6 years ago
3 files in the web directory:
example.webapp:
{
  "name": "My App",
  "description": "Testing the download bug",
  "launch_path": "/",
  "icons": {
    "128": "/img/icon-128.png"
  },
  "developer": {
    "name": "Your name or organization",
    "url": "http://example.org"
  },
  "default_locale": "en"
}

index.html:
<!DOCTYPE html>
<html lang="en-US">
	<head>
		<title>Bug example</title>
	</head>
	<body>
		<a href="example.doc">download this file, baby</a>
		<br />
		<br />
		<br />
		<button id="install-app">install webapp</button>
	</body>
	<script>
			var installApp = document.getElementById("install-app");
			if (installApp) {
				installApp.addEventListener("click", function() {
					var mozApps = navigator.mozApps;
					if (mozApps) {
						var installing = navigator.mozApps.install("http://test.plustour.net/example.webapp");
						installing.onsuccess = function(e) {
							var installApp = document.getElementById("install-app");
							installApp.textContent = "Already Installed";
							installApp.disabled = true;
						};
					}
				});
			}
		
	</script>
</html>

and a file for download... example.doc

The result is... The file can be downloaded using the browser (Firefox 22).
But if you click "install" and then open it as a web app... The file can not be downloaded.

Test it here:
http://test.plustour.net/
Flags: needinfo?(vkeranov)
(Reporter)

Comment 5

6 years ago
I think this one is the same:
https://bugzilla.mozilla.org/show_bug.cgi?id=851217

But obviously not for OS X only, happens on Windows too (tested on both Win 7 and Win XP).
Severity: normal → major
See Also: → bug 851217
Thank you, we'll track the work needed in bug 851217.
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 851217
(Reporter)

Comment 7

5 years ago
As I said in https://bugzilla.mozilla.org/show_bug.cgi?id=851217
With 27.0 we have a dialog box, which was the idea. But now every downloaded file has 0 bytes size.
The same files are Ok when downloaded via regular browser.
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
(In reply to vkeranov from comment #7)
> With 27.0 we have a dialog box, which was the idea. But now every downloaded
> file has 0 bytes size.
> The same files are Ok when downloaded via regular browser.

This is bug 965414.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.