Don't use static page size on ia64, sparc and mips

RESOLVED FIXED in Firefox 24

Status

()

Core
Memory Allocator
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

24 Branch
mozilla25
All
Linux
Points:
---

Firefox Tracking Flags

(firefox24 fixed, firefox25 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
ia64, sparc and mips have non 4k page sizes, and even a page size that varies depending on the kernel or maybe the cpu model.
(Assignee)

Comment 1

5 years ago
Created attachment 785361 [details] [diff] [review]
Don't use static page size on ia64, sparc and mips
Attachment #785361 - Flags: review?(justin.lebar+bug)
Attachment #785361 - Flags: review?(justin.lebar+bug) → review+
https://hg.mozilla.org/mozilla-central/rev/ec6bcb45443c
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
(Assignee)

Comment 3

5 years ago
Comment on attachment 785361 [details] [diff] [review]
Don't use static page size on ia64, sparc and mips

[Approval Request Comment]
Requesting for beta because i'd like this in ESR24 so that I don't have to carry the patch around for the ESR.
User impact if declined: Runtime failure because of page size size not matching what jemalloc expects on ia64, sparc and mips.
Testing completed (on m-c, etc.): Tested on a ia64, sparc and mips.
Risk to taking this patch (and alternatives if risky): NPOTB.
String or IDL/UUID changes made by this patch: None
Attachment #785361 - Flags: approval-mozilla-beta?

Updated

5 years ago
Attachment #785361 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/fc0020792338
status-firefox24: --- → fixed
status-firefox25: --- → fixed
This is the case on powerpc as well. Please add it to the list.

Note that this is a terrible design decision to begin with. I sincerely hope
the code can be reworked to no longer make that assumption (or at least stick
to something like "maximum" page size if that can help).
FWIW we saw a significant improvement on our whole-browser benchmarks when we switched to using a static page size.  Trading that for breakage on our tier-three platforms doesn't seem "terrible" to me.  I don't think we have any plans to get rid of this assumption for platforms where it's a correct assumption.
Assuming no verification needed here. Please add the verifyme keyword and remove the [qa-] whiteboard tag to request verification.
Whiteboard: [qa-]
(Assignee)

Updated

2 years ago
Duplicate of this bug: 819674
You need to log in before you can comment on or make changes to this bug.