Panning & zooming does still not work well on Browser after bug 866232

RESOLVED FIXED in mozilla26

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: julienw, Assigned: kats)

Tracking

25 Branch
mozilla26
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

6 years ago
I tried applying patches in bug 899810 and bug 900742 but zooming/panning on http://ratp.fr is still wrong:

* sometimes it just doesn't work
* sometimes the gesture to panning does zooming instead
* when zooming, the focal point is also still not right
(In reply to Julien Wajsberg [:julienw] from comment #0)
> * sometimes the gesture to panning does zooming instead

This one should be fixed by bug 898443. I will look into the other two parts of this.
Blocks: 866232
Depends on: 898443
No longer depends on: 866232
Version: 22 Branch → 25 Branch
Assignee: nobody → bugmail.mozilla
I have repro steps for this bug:

1. Launch the browser and navigate to a site, espacially one with lots of content (eg yahoo.com).
2. Scroll down and up the page.

The page will eventually freeze and become unresponsive, forcing the user to close the browser completely and reload it.  The length of time varies, but it's never more than a minute.
Posted patch PatchSplinter Review
This fixes a screwup on my part in bug 866232, part 8 (https://hg.mozilla.org/mozilla-central/rev/9a4478e65fd6). The original code had mFrameMetrics.mScrollOffset multiplied by "paintedScale" which was actually the CSSToLayerScale of the painted frame metrics rather than the APZC's internal frame metrics. In my refactoring I accidentally changed it to use the APZC's internal frame metrics instead. This fixes that and also factors out the multiplication.
Attachment #786955 - Flags: review?(bgirard)
:bbondy, can you also verify if the attached patch fixes the focal point when zooming for you?
Comment on attachment 786955 [details] [diff] [review]
Patch

Review of attachment 786955 [details] [diff] [review]:
-----------------------------------------------------------------

Yes this works a million times better now :)
Attachment #786955 - Flags: review?(bgirard) → review+
https://hg.mozilla.org/mozilla-central/rev/8427bf2c4652
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26

Updated

6 years ago
Blocks: 903498
You need to log in before you can comment on or make changes to this bug.