Downloads started in private mode are not listed in any download status

RESOLVED WORKSFORME

Status

()

Firefox
Private Browsing
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: ztowfic, Unassigned)

Tracking

23 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130803193131

Steps to reproduce:

1) Start a private browsing window.
2) Start a download (for example, 7zip)
3) If your settings dictate that you are asked where to save the file, then go ahead and tell it where to save.


Actual results:

Interestingly, the download actually begins and is conducted correctly. But there is no record of this download anywhere, and you cannot see the progress of the download (if it is a large file, for example) anywhere in firefox. The only way I knew the progress is by going to the directory where the download is being saved and looking at the file size of the .part file.


Expected results:

the download should be listed in the private window's downloads (about:downloads) while it is being downloaded and should continue to be listed there until the user exits the private browsing window. These downloads should never be listed in the regular window's downloads.

Updated

4 years ago
Component: Untriaged → Private Browsing

Comment 1

4 years ago
The download should be listed in both the download panel (click the glowing green arrow), and the tab that appears when you click "Show all downloads" in the panel. If this doesn't happen, can you give some specific sites and steps that reproduce this behaviour for you?
Flags: needinfo?(ztowfic)
(Reporter)

Comment 2

4 years ago
I am running Firefox 23 under KDE on Ubuntu 12.10. I start a private window, and go to http://plasma-active.org/. At the top right, there is a link for "Download as OGG video." I right-click and "save link as" and select my downloads folder. Once I hit save/ok, it is as though nothing happened in firefox. The arrow is still gray (between the home and reload buttons) and if I select the arrow and click "show all downloads," then the downloads tab is empty.

When I go to my download folder though, the download has been completed as expected---it is just that firefox has no record of this.
Flags: needinfo?(ztowfic)
(Reporter)

Comment 3

4 years ago
(This issue did not happen with Firefox 22 --- which I updated to Firefox 23 yesterday).

Comment 4

4 years ago
It shows up in my download panel just fine on Fedora 18, Gnome 3. What happens if you run in safe mode to disable any addons you have?
(Reporter)

Comment 5

4 years ago
I see, the bug is in the extension "Download Statusbar," which is too bad since I liked that extension. I disabled it and everything is fine now.

Sorry to file in the wrong place!

Comment 6

4 years ago
Thanks, this add-on needs surely to be updated since the new download panel and PB mode.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Duplicate of this bug: 903730
You need to log in before you can comment on or make changes to this bug.