Page not displayed after switching tabs

VERIFIED FIXED in Firefox 25

Status

()

Firefox for Android
General
--
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: nthomas, Assigned: wesj)

Tracking

unspecified
Firefox 26
x86
Android
Points:
---

Firefox Tracking Flags

(firefox24 unaffected, firefox25+ verified, firefox26+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:
1, open a webpage (eg http://www.nzherald.co.nz)
2, open a couple of links in new tabs
3, switch between the tabs

The first page is still displayed properly on switch, but the two others are displayed as a blank white page. Reloading a blank page gets you the first page, rather than what you had opened.

This broke in the 20130803 nightly build on m-c, bisected to inbound:
last good: f85f06761d52
http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android/1375396141/fennec-25.0a1.en-US.android-arm.apk

first bad: 82c3a4ad5d69
http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android/1375397214/fennec-25.0a1.en-US.android-arm.apk

So fingering bug 895655.

Comment 1

5 years ago
E/GeckoConsole(20180): [JavaScript Error: "ReferenceError: resolveGeckoUri is not defined" {file: "chrome://browser/content/browser.js" line: 1641}]
(Assignee)

Comment 2

5 years ago
Created attachment 785934 [details] [diff] [review]
Follow up

Doh. I fixed this to make my addon work. I must have forgotten to qref some changes or something...
Assignee: nobody → wjohnston
Attachment #785934 - Flags: review?(margaret.leibovic)

Comment 3

5 years ago
Comment on attachment 785934 [details] [diff] [review]
Follow up

Sorry I didn't catch this in the review!
Attachment #785934 - Flags: review?(margaret.leibovic) → review+
(Assignee)

Comment 5

5 years ago
Comment on attachment 785934 [details] [diff] [review]
Follow up

We need to uplift this to Aurora 25.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 895655
User impact if declined: pages that have reader mode can't be switched to
Testing completed (on m-c, etc.): landed on mc now
Risk to taking this patch (and alternatives if risky): low risk. fix of a stupid mistake
String or IDL/UUID changes made by this patch: none
Attachment #785934 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/ccf62e58c732
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26

Updated

5 years ago
Duplicate of this bug: 901932

Updated

5 years ago
status-firefox24: --- → unaffected
status-firefox25: --- → affected
status-firefox26: --- → fixed
tracking-firefox25: --- → +
tracking-firefox26: --- → +

Updated

5 years ago
Attachment #785934 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
status-firefox25: affected → fixed

Comment 9

5 years ago
Verified as fixed on:
Build: Nightly 26.0a1 (2013-08-19) / Aurora 25.0a2 (2013-08-19)
Device: HTC Desire HD (Android 2.3.5)
status-firefox25: fixed → verified
status-firefox26: fixed → verified

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.