Closed Bug 901456 Opened 7 years ago Closed 7 years ago

Intermittent TEST-UNEXPECTED-FAIL | /tests/dom/devicestorage/test/test_lastModificationFilter.html | when the enumeration is done, we shouldn't have any files in this array

Categories

(Core :: DOM: Core & HTML, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla28
Tracking Status
firefox26 --- fixed
firefox27 --- fixed
firefox28 --- fixed
firefox-esr24 --- unaffected
b2g-v1.2 --- fixed

People

(Reporter: cbook, Assigned: dhylands)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

Ubuntu VM 12.04 mozilla-inbound opt test mochitest-2 on 2013-08-04 21:39:59 PDT for push abc285ee0cd1

slave: tst-linux32-ec2-062

TEST-UNEXPECTED-FAIL | /tests/dom/devicestorage/test/test_lastModificationFilter.html | when the enumeration is done, we shouldn't have any files in this array
OS: Mac OS X → Linux
Duplicate of this bug: 930448
Assignee: nobody → dhylands
Attachment #8334971 - Flags: review?(Jan.Varga)
Ok, I'll take a look tomorrow.
Comment on attachment 8334971 [details] [diff] [review]
Make sure that file timestamps change between the old and new files. v2

Review of attachment 8334971 [details] [diff] [review]:
-----------------------------------------------------------------

looks good, nice cleanup!

::: dom/devicestorage/test/test_lastModificationFilter.html
@@ +129,5 @@
>  }
>  
> +function waitForTimestampChange() {
> +  // We've added a new file. See if the timestamp differs from
> +  // oldFileAddedTimestamp, and if its the same wait for a bit

Nit: it's ?
Attachment #8334971 - Flags: review?(Jan.Varga) → review+
Backed out and re-landed with the correct bug number.
https://hg.mozilla.org/integration/b2g-inbound/rev/f1bd202062c9
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #46)
> Backed out and re-landed with the correct bug number.
> https://hg.mozilla.org/integration/b2g-inbound/rev/f1bd202062c9

Damn - that's twice I've done that recently. Thanks for the correction.
https://hg.mozilla.org/mozilla-central/rev/f1bd202062c9
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.