Let Skia/GL 2D canvases use multiplexed GLContexts

RESOLVED INVALID

Status

()

Core
Canvas: 2D
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: bjacob, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

This is key to reasonable memory usage with Skia/GL and would match what we're already doing with Direct2D, and how Chrome is using Skia/GL.

That however depends on GLContext becoming multiplexable (bug 901503) which itself depends on the GLContext refactoring (bug 901498).
Benoit, is this a duplicate of the (later, but more active) bug 939276?
Flags: needinfo?(bjacob)
(Reporter)

Comment 2

5 years ago
Not really a duplicate, rather it's deprecated by it.

What we want is 1) do bug 939276 , 2) enable GLContext multiplexing  3) start using GLContext multiplexing for all canvas rendering, across different context types (2D vs WebGL) so that e.g. the Gallery app would only need 1 canvas anymore.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(bjacob)
Resolution: --- → INVALID
(Reporter)

Comment 3

5 years ago
(would only need 1 *opengl context* anymore)
You need to log in before you can comment on or make changes to this bug.