Last Comment Bug 901544 - Permanent Orange: TEST-UNEXPECTED-FAIL | test_partsOnDemand.js/test_attachment_size.js | logHelper.js | Error console says [stackFrame NS_ERROR_FAILURE: ...
: Permanent Orange: TEST-UNEXPECTED-FAIL | test_partsOnDemand.js/test_attachmen...
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: MIME (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 26.0
Assigned To: Mark Banner (:standard8)
:
Mentors:
Depends on:
Blocks: 896738
  Show dependency treegraph
 
Reported: 2013-08-05 08:10 PDT by Mark Banner (:standard8)
Modified: 2013-08-08 08:22 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
Remove mailDirService uses (35.26 KB, patch)
2013-08-08 04:00 PDT, Mark Banner (:standard8)
Pidgeot18: review+
Details | Diff | Splinter Review
Remove mailDirService (4.75 KB, patch)
2013-08-08 04:01 PDT, Mark Banner (:standard8)
Pidgeot18: review+
Details | Diff | Splinter Review
Fix the tests - provide UMimTyp (2.74 KB, patch)
2013-08-08 04:11 PDT, Mark Banner (:standard8)
Pidgeot18: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑beta+
Details | Diff | Splinter Review

Description Mark Banner (:standard8) 2013-08-05 08:10:42 PDT
This has been failing since the last major orange:

TEST-INFO | (xpcshell/head.js) | test _async_driver finished (2)
System JS : ERROR resource://gre/components/nsHandlerService.js:891
                     NS_ERROR_FAILURE: 'Failure' when calling method: [nsIDirectoryServiceProvider::getFile]

TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame NS_ERROR_FAILURE: 'Failure' when calling method: [nsIDirectoryServiceProvider::getFile]] - See following stack:
JS frame :: ../../../resources/logHelper.js :: _errorConsoleTunnel.observe :: line 63
native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
Comment 1 Mark Banner (:standard8) 2013-08-05 08:11:06 PDT
Also in test_attachment_size.js
Comment 2 Mark Banner (:standard8) 2013-08-08 04:00:05 PDT
Created attachment 787434 [details] [diff] [review]
Remove mailDirService uses

I was looking at this today, there's two parts I'm going to cover here.

mailDirService was set up to provide a registration for ProfD to the directory service provider. I was trying to use it to fix this bug and it wasn't working.

That's when I discovered that bug 459114 had effectively made mailDirService and all it was designed to do redundant.

Hence, we can just drop mailDirService and not have it getting in the way (this should also fix some of the removing directory issues we see on Beta on windows).

This patch removes all references to mailDirService.js
Comment 3 Mark Banner (:standard8) 2013-08-08 04:01:50 PDT
Created attachment 787435 [details] [diff] [review]
Remove mailDirService

Removes the redundant module.
Comment 4 Mark Banner (:standard8) 2013-08-08 04:11:26 PDT
Created attachment 787439 [details] [diff] [review]
Fix the tests - provide UMimTyp

This fixes the tests by setting up a provider for UMimTyp to the directory service.

These three patches pushed to try server here:

https://tbpl.mozilla.org/?tree=Thunderbird-Try&rev=8cf49469b1ff
Comment 6 Mark Banner (:standard8) 2013-08-08 07:23:10 PDT
Comment on attachment 787439 [details] [diff] [review]
Fix the tests - provide UMimTyp

[Triage Comment]
These three have a=me as they are unit test fixes that we need.

Note You need to log in before you can comment on or make changes to this bug.