WebGL canvas disappears after a few seconds

RESOLVED DUPLICATE of bug 917160

Status

()

defect
RESOLVED DUPLICATE of bug 917160
6 years ago
6 years ago

People

(Reporter: ashley, Assigned: jgilbert)

Tracking

(Blocks 1 bug, {regression})

22 Branch
x86_64
Windows 8
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox22 affected, firefox23 affected, firefox24 affected, firefox25 affected, firefox26 affected)

Details

(Whiteboard: [games:p1] webgl-conformance, URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.95 Safari/537.36

Steps to reproduce:

1. Visit http://www.scirra.com/demos/c2/watertransition/
2. Wait 2-10 seconds


Actual results:

After a few moments, the screen goes black.


Expected results:

The screen should never go black - it should keep rendering the same thing.
(Reporter)

Comment 1

6 years ago
Some technical details: this is made with the Construct 2 HTML5 engine, rendering to HTML5 canvas using a WebGL context. Our game loop is based on requestAnimationFrame. If nothing changes on the screen, it does not issue any draw calls. It appears if no draw calls are made to a WebGL context, after a few seconds Firefox blanks out the canvas. As soon as draw calls are made again, it comes back (click the screen after it's gone blank and a shader transition starts running).

Our users tell us this is affecting stable Firefox, and I've verified Nightly 25.0a1 is affected too. All Construct 2 games are affected from what we can tell. The workaround is to keep re-drawing the whole game every requestAnimationFrame, but that is a waste of resources when nothing is changing on-screen.
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
(Reporter)

Comment 2

6 years ago
Note also that Chrome 28 is not affected.
So my quick investigation...

* load the page
* accept the storage
* page blanks
* clicking causes the canvas to update

* Shift reloading the page while the mouse cursor is outside the content results in the canvas staying visible
* mousing over the content window causes the canvas to immediately blank
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

6 years ago
Also note that this is a regression, and it worked correctly in prior versions of Firefox.
(Assignee)

Comment 5

6 years ago
This sounds a lot like snapshotting issues, again.

Comment 6

6 years ago
Steps to reproduce:
1. Visit http://www.scirra.com/demos/c2/watertransition/
2. Mouse over bookmark on Bookmarks toolbar OR menu on MenuBar

1st Regression window:
Good:
http://hg.mozilla.org/mozilla-central/rev/d57a813c77a4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130220 Firefox/22.0 ID:20130220165456
Bad:
http://hg.mozilla.org/mozilla-central/rev/702d2814efbf
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130221 Firefox/22.0 ID:20130221050602
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d57a813c77a4&tochange=702d2814efbf
Regressed by:
	82747d694e7a	Jeff Gilbert — Bug 716859 - Streaming GLContext buffers (doublebuffering, etc) - r=bjacob,jrmuizel,vlad

Working window:
Bad:
http://hg.mozilla.org/mozilla-central/rev/702d2814efbf
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130221 Firefox/22.0 ID:20130221050602
Good, Working again:
http://hg.mozilla.org/mozilla-central/rev/885cde564ff3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130221 Firefox/22.0 ID:20130221115546
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=702d2814efbf&tochange=885cde564ff3
Working again:
  885cde564ff3	Ed Morley — Backed out changeset 82747d694e7a (bug 716859) for android reftest-2 timeouts

2nd regression window
Good:
http://hg.mozilla.org/mozilla-central/rev/e946347c031f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130222 Firefox/22.0 ID:20130222081706
Bad, Broken again:
http://hg.mozilla.org/mozilla-central/rev/e36f42046452
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130222 Firefox/22.0 ID:20130222094333
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e946347c031f&tochange=e36f42046452

Regressed again by:
  3a7d4085787e	Jeff Gilbert — Bug 716859 - Streaming GLContext buffers (doublebuffering, etc) - r=bjacob,jrmuizel,vlad
  6c64bae71de5	Jeff Muizelaar — Bustage fix for bug 716859. r=bjacob,joe CLOSED TREE Don't try to pass the conformance tests if we've disabled webgl.
Blocks: 716859
Version: 25 Branch → 22 Branch
Jeff, you're ok with this assigned to you?
Assignee: nobody → jgilbert
Recent regression, breaks real-world applications, therefore games:p1
Whiteboard: [games:p1]
Whiteboard: [games:p1] → [games:p1] webgl-conformance
(Reporter)

Comment 9

6 years ago
Looks like it might be fixed in Nightly 27.0a1. Can anyone confirm?

Comment 10

6 years ago
I can reproduce the problem easily if Firefox start with new profile.
(But when Firefox start with existing profile, it slightly difficult to reproduce.)

http://hg.mozilla.org/mozilla-central/rev/b5d24ef1eb37
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131005030203

STR
1. Start with newly created profile
2. Open URL
3. Wait for a 10 sec after display completion of the image
4. Move mouse pointer to the tab(or new tab button) slowly

Actual Results:
The contents area becomes black
(Assignee)

Comment 11

6 years ago
This might be bug 917160.
(Assignee)

Comment 12

6 years ago
This is very likely fixed by bug 917160. Can you still reproduce this?
Flags: needinfo?(ashley)
(Reporter)

Comment 13

6 years ago
Can't reproduce in Nightly 27.0a1 2013-10-09. Looks good to me now.
Flags: needinfo?(ashley)

Comment 14

6 years ago
I also can't reproduce the problem with 27.0a1 2013-10-10.

Comment 15

6 years ago
Fixed window(m-c)
Bad:
http://hg.mozilla.org/mozilla-central/rev/56b0a41985f3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131007184923
Fixed:
http://hg.mozilla.org/mozilla-central/rev/67595062eee3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131008043852
Fixed  Pushlog: 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=56b0a41985f3&tochange=67595062eee3

Fixed by:
	1134b18371d3	Jeff Gilbert — Bug 917160 - AssureBlitted before switching EGLSurfaces with MakeCurrent. - r=bjacob
Depends on: 917160

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 917160
You need to log in before you can comment on or make changes to this bug.