[PP] Click Send in compose window results in a crash

VERIFIED FIXED in M8

Status

SeaMonkey
MailNews: Message Display
P1
blocker
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: lchiang, Assigned: Alec Flett)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
[PP] Click Send in compose window results in a crash

1999062909 build of Win32
Linux does not have this problem
Mac builds not available yet

1) Start Messenger
2) New Message
3) Type in a recipient, subject, body and send the message
4) Crash occurs
No Talkback report available since Talkback doesn't seem to engage in this
build.

Note:
cc'ing alecf since he checked in multiple identities in mail compose for today's
build - the "from" field in my mail compose window is blank.  I'm using the same
prefs I've always used

Also, interestingly, a plain text mail compose window came up instead of the
html compose window.

Would like fixed as soon as possible.  Thanks.
(Assignee)

Updated

19 years ago
Assignee: phil → alecf
(Assignee)

Comment 1

19 years ago
I'm sure this is me. Stealing from phil.

Comment 2

19 years ago
I get the following stack where identity is null in SendMsgEx.  Also, my compose
window has no identities listed in the "from" pulldown.

nsMsgCompose::SendMsgEx(nsMsgCompose * const 0x0533a130, int 0, nsIMsgIdentity *
0x00000000, const unsigned short * 0x052cb8c0, const unsigned short *
0x0012e228, const unsigned short * 0x0012e170, const unsigned short *
0x0012e26c, const unsigned short * 0x0012e1ac, const unsigned short *
0x052f48c0, const unsigned short * 0x00000000) line 347 + 31 bytes
nsMsgCompose::SendMsg(nsMsgCompose * const 0x0533a130, int 0, nsIMsgIdentity *
0x00000000, const unsigned short * 0x00000000) line 312
XPTC_InvokeByIndex(nsISupports * 0x0533a130, unsigned int 6, unsigned int 3,
nsXPTCVariant * 0x0012e3fc) line 135
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x0519be60,
nsXPCWrappedNative * 0x0533ba40, const XPCNativeMemberDescriptor * 0x0533bd40,
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 3, long *
0x04779f30, long * 0x0012e604) line 511 + 44 bytes
WrappedNative_CallMethod(JSContext * 0x0519be60, JSObject * 0x04758650, unsigned
int 3, long * 0x04779f30, long * 0x0012e604) line 128
js_Invoke(JSContext * 0x0519be60, unsigned int 3, int 0) line 655 + 26 bytes
(Reporter)

Comment 3

19 years ago
*** Bug 9019 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
The bit about a plain text window coming up instead of html also happens on
today's Linux build.
(Reporter)

Comment 5

19 years ago
<Stacey - can you file a separate bug on html not being the default compose
window any more?  Thanks>

Comment 6

19 years ago
<Sure; actually, it looks like it's just a requirement for the new compose_html
pref to be present.>
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

19 years ago
Ok, looks like the crash is because I was dereferencing a null pointer without
checking it first. I've checked in a fix for that (update
mozilla/mailnews/compose/src/nsMsgCompose.cpp)

The null identity seems to be because XPConnect can't find the interface
definition for nsISupportsArray or something. It's very strange...continuing to
investigate.
(Assignee)

Updated

19 years ago
Priority: P3 → P1
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

19 years ago
Ok, I think I found the problem.
On windows, XPConnect is not resolving nsISupportsArray correctly, I'm not sure
why... in any case, what I did was to put
#include "nsISupportsArray.idl"

in all of the IDL files in msgbase.xpt (mozilla/mailnews/base/public) so that
the resulting XPT file had the IID of nsISupportsArray, instead of our old hack
of putting
interface nsISupportsArray;
%{C++
#include "nsISupportsArray.h"
%}

This also makes the identities appear in the From: line, which scott reported
was missing.

You can fix the build without respinning by putting the attached msgbase.xpt in
your components directory.
(Assignee)

Comment 9

19 years ago
Created attachment 606 [details]
XPT typelibrary which has nsISupportsArray resolved

Updated

19 years ago
Target Milestone: M8

Comment 10

19 years ago
Putting on M8 radar since it was blank..and this is fixed during M8 :-)
(Reporter)

Comment 11

19 years ago
alec - is your fix cross-platform?  Today's Mac build from this morning (which
we just got) has the same problem with crash on send.  Thanks.
(Assignee)

Comment 12

19 years ago
sounds like mac and windows have the same xpconnect bug (or Linux has a wierd
XPConnect "feature") - the fix affects all platforms, so it should help mac too
if it has this problem.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 13

19 years ago
OK using jul12 m8 builds on Linux, NT 4.0 and Mac OS 8.51
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.