Sort by date should start by sorting ascending, not descending

RESOLVED DUPLICATE of bug 80936

Status

RESOLVED DUPLICATE of bug 80936
5 years ago
3 years ago

People

(Reporter: huji.huji, Unassigned)

Tracking

17 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130627185035

Steps to reproduce:

1) Click on Subject (or any other column than Date) to sort emails based on that characterisitc.

2) Now click on Date to sort the threads by date.


Actual results:

The email threads are sorted by date, oldest on top.


Expected results:

Naturally, you want the newest email on top, not the oldest. The default sort for most email providers (webmail and otherwise) is to sort by age, newset first.

Right now, you have to click TWICE on the Date column to get to the natural order; the extra click is unnecessary and has to be eliminated. The default sort order for Date column should be newest to oldest, not oldest to newest.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 80936
You need to log in before you can comment on or make changes to this bug.