Focus events not being sent to Shockwave

VERIFIED FIXED in mozilla0.9.3

Status

()

P1
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: shrir, Assigned: peterlubczynski-bugs)

Tracking

({regression})

Trunk
mozilla0.9.3
PowerPC
Mac System 9.x
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
mac branch build 0710

this seems to have regressed due to last night's checkin...

Keyboard events are not getting registered...

try faceball under games|sports...

blocks all games that involve keyboard interaction..
(Assignee)

Comment 1

18 years ago
I think this is a regression, I'll try to get a patch made up right away.
Status: NEW → ASSIGNED
Keywords: regression
Priority: -- → P1
Target Milestone: --- → mozilla0.9.3

Comment 2

18 years ago
Mark PDT+ to get on radar.  This seems like a stop ship for plugins. 
Hardware: PC → Macintosh
Whiteboard: [PDT+]
(Assignee)

Comment 3

18 years ago
Rephrasing summary.

Without focus events being sent to Shockwave, key events won't work.

Shrirang, just to be clear on the old summary, keyboard do work on other plugins
on Mac like Flash, right? For example, at http://www.emailtrack.com
Summary: keyboard events are not working on mac → Focus events not being sent to Shockwave
Whiteboard: [PDT+] → [PDT+][ETA Wednesday]
(Reporter)

Comment 4

18 years ago
yep,that's right
(Assignee)

Comment 5

18 years ago
Created attachment 41937 [details] [diff] [review]
patch to fix this
(Assignee)

Comment 6

18 years ago
Andrei, can you review this patch?

It seems to fix it for the Mac. For some reason, a focus event isn't a
nsGUIEvent. This was making OS X crash. It doesn't matter because all we care
about is that it's a focus event and then we do something special with that in
ProccessEvent(). The memset() ensures we don't crash doing any casts later as we
have checks for null. 
Whiteboard: [PDT+][ETA Wednesday] → [PDT+][ETA Wednesday][seeking reviews]

Comment 7

18 years ago
OK, r=av

Comment 8

18 years ago
OK, as long as you are sure that memset on the structure is sufficient to
initialize it to a safe state, sr=attinasi
(Assignee)

Comment 9

18 years ago
Patch is in the branch. I'll guess I'll get the trunk tomorrow when it opens.
/cvsroot/mozilla/layout/html/base/src/nsObjectFrame.cpp,v
new revision: 1.226.2.5; previous revision: 1.226.2.4
Whiteboard: [PDT+][ETA Wednesday][seeking reviews] → [PDT+][vbranch][patch in branch]
(Assignee)

Comment 10

18 years ago
Patch in the trunk, marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+][vbranch][patch in branch] → [PDT+][vbranch]

Comment 11

18 years ago
Thanks, pls verify when you get a chance, shrir. Thanks!
Whiteboard: [PDT+][vbranch] → [PDT+]

Comment 12

18 years ago
Shrir will be back on Wednesday.
(Reporter)

Comment 13

18 years ago
verified this one on mac branch 0718. things look good , focus events are 
working now. Added 'vtrunk' for trunk verification later. marking VERIF
Status: RESOLVED → VERIFIED
Keywords: vtrunk
(Reporter)

Comment 14

18 years ago
verif on mac trunk 0801, removing 'vtrunk'
Keywords: vtrunk
You need to log in before you can comment on or make changes to this bug.