[B2G] [Unagi] [1.2] [Email] Error message appears after viewing attached photo from a received email

RESOLVED DUPLICATE of bug 861328

Status

RESOLVED DUPLICATE of bug 861328
5 years ago
5 years ago

People

(Reporter: ckreinbring, Unassigned)

Tracking

({smoketest})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 785996 [details]
Log of receiving email and viewing photo attachment

Description:
Attempting to view a photo that's attached to an email will generate an error message and prevent the user from viewing the photo.  However, the photo is saved to the gallery and is able to be viewed normally from the gallery.

Repro Steps:
1) Update Unagi to Build ID: 20130805070203
2) Launch the Email app and login with a valid username and password.
3) Have another account send an email with a picture attached to the account set up in the previous step.
4) Tap the Refresh softkey and select the email when it appears.
5) Tap the download button, then tap the View button whe it appears.
6) Observe the page that appears.

Actual:
The attached picture shows momentarily before an error message is superimposed over it stating "Image is invalid or corrupt and cannot be displayed".

Expected:
The attached picture is shown with no error messages present.

Environmental Variables
Occurs on Unagi 1.2 mozilla RIL
Build ID: 20130805070203
Gecko: http://hg.mozilla.org/mozilla-central/rev/ad0ae007aa9e
Gaia: 0ca0dba246d1372eb815772c8108395ab0abd0a4
Platform Version: 25.0a1

Notes:
Repro frequency: 100%
See attached screenshot and logcat logs
Video and music files can be viewed with no errors.
(Reporter)

Comment 1

5 years ago
Created attachment 786004 [details]
Screenshot of error message
This seems like a very similar phenomenon to what's happening on bug 861328.  There we receive the error when you attempt to zoom the image.  Since you see the image before the error, this sounds nearly identical.  In that bug, I verified that e-mail was writing the image to disk correctly; md5sum of the downloaded attachment matched the sent one.  So this seems like a gallery problem or a platform betrayal that's impacting gallery.  Duping to bug 861328.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Component: Gaia::E-Mail → Gaia::Gallery
Resolution: --- → DUPLICATE
Duplicate of bug: 861328
You need to log in before you can comment on or make changes to this bug.