[B2G][Helix][Gaia]There is flash when automatically adjusting the screen brightness.

RESOLVED INVALID

Status

Firefox OS
Gaia::System
P2
normal
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: lecky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E)

Steps to reproduce:

1.Put the device under a light.
2.Block the window of light sensor.


Actual results:

The screen brightness automatically adjusted to a lower brightness.
But there is flash in the process of adjustment.


Expected results:

The process of adjustment should be smooth.Can not feel flashing.

If modify these constants in screen_manager.js, the flash will disappear.

  /*
   * When we change brightness we animate it smoothly.
   * This constant is the number of milliseconds between adjustments
   */
  BRIGHTNESS_ADJUST_INTERVAL: 10,

  /*
   * When brightening or dimming the screen, this is how much we adjust
   * the brightness value at a time.
   */
  BRIGHTNESS_ADJUST_STEP: 0.004,

Please help to check, thanks.
(Reporter)

Updated

5 years ago
Priority: -- → P2
Marco, I think this somehow needs to be adjusted on OEM side, can you share some insights?
Flags: needinfo?(mchen)

Comment 2

5 years ago
Hi Lecky,

If you think this is correct for the Helix then it is welcome to contribute it here.

We will check the flash is coming from which part.
ex: unstable light sensor value or unstable backlight levels or...
Flags: needinfo?(mchen) → needinfo?(lecky.wanglei)

Comment 3

5 years ago
Hi Viral,

Could you help to check the reason of the unstable transition caused by light sensor? Thank.
Flags: needinfo?(vwang)

Comment 4

5 years ago
in latest image (20130805), I didn't see the flash when auto backlight.
I check the data of light sensor looks smooth, I can see the range is 0-6 in my side.
backlight brightness also looks good to me should be no flash.
W/lights  (  160): LCD backlight current value =109
W/lights  (  160): LCD backlight current value =119
W/lights  (  160): LCD backlight current value =129
W/lights  (  160): LCD backlight current value =139
W/lights  (  160): LCD backlight current value =149
W/lights  (  160): LCD backlight current value =159
W/lights  (  160): LCD backlight current value =169
W/lights  (  160): LCD backlight current value =179
W/lights  (  160): LCD backlight current value =189
W/lights  (  160): LCD backlight current value =193
W/lights  (  160): LCD backlight current value =203
W/lights  (  160): LCD backlight current value =213
W/lights  (  160): LCD backlight current value =214
W/lights  (  160): LCD backlight current value =204
W/lights  (  160): LCD backlight current value =194
W/lights  (  160): LCD backlight current value =193
W/lights  (  160): LCD backlight current value =183
W/lights  (  160): LCD backlight current value =173

if the flash can be observe easily, may I have video to check the symptom?
Thank you.
Flags: needinfo?(vwang)
(Reporter)

Comment 5

5 years ago
Hi Viral, 

If adjust between level1(69) and level2(162), the flash will be observed easily.
The current delta is 10, it's too large, I think it's the cause of flash.

Please check, thanks!
Flags: needinfo?(lecky.wanglei)

Comment 6

5 years ago
Hi Lecky,

As our discussion, my suggestion will be changing following parameters in your side.

BRIGHTNESS_ADJUST_INTERVAL
BRIGHTNESS_ADJUST_STEP
(Reporter)

Comment 7

5 years ago
OK, thank you!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.