Closed Bug 901967 Opened 9 years ago Closed 4 years ago

Instant Fox in FF23 causing issues when searching

Categories

(Firefox :: Extension Compatibility, defect)

defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox23 --- affected
firefox24 --- affected

People

(Reporter: bsullins, Unassigned)

Details

I just upgraded to FF23 and I have InstantFox which I use religiously for searching. Now it appears when I start typing a search into the address bar it always pulls up the Acronym Finder search option.

Here is a video of this bug in action: http://www.screencast.com/t/A2nsux7gSn8N

Please advise a workaround.

Thanks!
wow, okay, this seems to be happening even w/ the InstantFox plugin disabled.
Component: Extension Compatibility → Location Bar
What search provider do you have selected in the firefox search field? (not visible in your screencast)

The keyword.URL has been removed in firefox, and i suspect that is what causes this effect for you.
Flags: needinfo?(bsullins)
Yeah, we made the search bar control what search engine gets used everywhere. Your search bar seems to have been customized away, so you probably didn't notice that the search engine you selected there was Acronym Finder.

If you add the search bar back and switch its selection to Google, that should "fix" things for you.

We may want to "reset" the selected search engine for people with hidden search bars, to avoid any similar confusion :(
Component: Location Bar → Search
OS: Mac OS X → All
Hardware: x86 → All
Yeah, it looks like when I disabled InstantFox AcronymFinder was set as the default search provider. I changed it to Google as the default and now it appears to work correctly.

The strange thing is I don't ever recall setting AcronymFinder as my default search provider, and prior to upgrade, this exact same behavior would yeild Google Search results.

Perhaps during the upgrade the first search provider in alphabetical order was set as my default over Google? Just thinking out loud...
Flags: needinfo?(bsullins)
Can we get QA to confirm that this isn't a reproducible issue with addons that alter the default search?  Users should be able to:

1. Install an addon which changes default search engine
2. Use the custom engine
3. Uninstall or disable the addon
4. Have their default search engine returned to our default (currently Google)

If this can't be reproduced then we're fine, but let's just make sure that we're getting this expected behaviour.
Keywords: qawanted
It's also possible that InstantFox specifically is breaking things, they seem to do a lot of weird stuff with search engines.
I can't reproduce this issue with Firefox 23 on Ubuntu 12.10 32bit

-- after installing InstantFox 2.8.3 add-on (on a clean profile), Google stays the selected search engine, and all searches are performed with it (search bar, URL bar, about:home and contextual menu)  (1) ; also, I don't see InstantFox listed in the Search Engine List (near the search bar)

-- indeed, after the add-on is installed, the search bar is hidden

-- after installing Acronym Finder from https://addons.mozilla.org/en-US/firefox/addon/acronym-finder/?src=search, I get the same behavior as (1); this time, Acronym Finder is listed in the Search Engine List (near the search bar)

-- after selecting Acronym Finder from the search bar, all searches are performed with it, except for the contextual menu search, which is still using Google; 

-- after uninstalling InstantFox 2.8.3 add-on, Google is the search engine used
QA Contact: manuela.muntean
(In reply to Manuela Muntean [:Manuela] [QA] from comment #7)
> -- after selecting Acronym Finder from the search bar, all searches are
> performed with it, except for the contextual menu search, which is still
> using Google; 

This seems unexpected. Does this happen without InstantFox installed?
> > -- after selecting Acronym Finder from the search bar, all searches are
> > performed with it, except for the contextual menu search, which is still
> > using Google; 
> 
> This seems unexpected. Does this happen without InstantFox installed?

No, without InstantFox installed, all 4 searches are performed by Acronym Finder (using the same OS and Firefox 23)
Gavin what are your thoughts here ? Sounds like a Fx 24 regression.
InstantFox doesn't seem to have liked the changes in bug 738818. We should reach out to their developers, I'll try Twitter and email.
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #11)
> InstantFox doesn't seem to have liked the changes in bug 738818. We should
> reach out to their developers, I'll try Twitter and email.

Thanks. I am needinfo'ing :jorgev as well to help with outreach if he has/knows a contact for this add-on..
Flags: needinfo?(jorge)
I just pinged them about this bug.
Flags: needinfo?(jorge)
Keywords: qawanted
Not tracking this as this is a TE issue.

gavin, let us know if you heard back from them as Jorge mentioned in the channel meeting that he had no luck yet.

Also, if you think there is anything we could/should do at our end , feel free to renom.
Component: Search → Extension Compatibility
This is about a legacy extension which is no longer valid in Firefox Quantum, closing.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.