Add an extension to “vote with your money”, Kickstarter-style.

RESOLVED DUPLICATE of bug 124096

Status

()

Bugzilla
Extensions
--
enhancement
RESOLVED DUPLICATE of bug 124096
5 years ago
5 years ago

People

(Reporter: Navid Zamani, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
This is a request to enable Bugzilla to be used for a new business model to finance F/LOSS projects, removing all concerns regarding to financing something that can be infinitely and uncontrollably copied.

The idea is that, since software, being information, can never be a “product”, but making software is a /service/,
adopting a service business model, just like every other service-based industry, where one gets paid for actual work (instead of stealing money from them in return for worthless copies), is the ideal way to go.

So to get paid for their service, developers can set a price (in whatever currency or “currency” they like) they minimally need for a bug / feature to be worth doing. And end-users can then vote with their wallets, Kickstarter-style, using an extension of the currently existing voting system, using micro-payment provider modules. If the votes go over the set price, the work will be done (on pre-agreed terms and conditions). If it doesn’t, it stays in there, unless the developer chooses to do it anyway, e.g. out of personal preference.
The developer can decide if, when it’s done, only those who voted get a copy, or just everyone. (The former only makes sense, if those people can keep it a secret, the developer wants to only partially go F/LOSS, and nobody can make e.g. a $0.01 vote just to get a copy. So basically never.)

The nice thing is, that this has absolutely zero disadvantages, but completely solves the problem of rewarding people for their work while staying 100% open, improves listening to the user base, and most of all: It makes any form of copy “protection” or “right”, including lies like imaginary “property”, completely pointless and unnecessary. (Not that they ever worked or were legitimate in the first place.)

The only thing “lost” will be the ability of organized crime, to hand out mere worthless *copies* that took *zero* work to make every time except the first, in return for real actual money that took real actual work to make *every* time. (Aka fraud.)
Which of course is a good thing for everyone except the economically pointless “publishers”.

I realize this is a lot to ask from or swallow for some people, who lived in the “old media” mindset all their lives, and may have trouble thinking the legitimate way. But it will benefit everybody, can run in parallel with everything else, is individually optional, and does no harm.
So… why not start something great?

Comment 1

5 years ago
As you say, this should be implemented as an extension and so is outside the core development of Bugzilla.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 124096
(Reporter)

Comment 2

5 years ago
(In reply to Frédéric Buclin from comment #1)

> *** This bug has been marked as a duplicate of bug 124096 ***
Hey Frédéric,
I have to stress that this is NOT a request to simply allow an ability to fund bugs. It comes with *very specific* rules for how this is done. Break one rule, and the entire concept falls apart and gets distorted to its opposite.
So while this is a partial overlap/duplicate with that other bug, it is the *differences* that this is all about.

> As you say, this should be implemented as an extension and so is outside the core development of Bugzilla.

I thought selecting “Component: Extensions” said that. But I disagree that it isn’t a core element. I’d say it’s kinda THE point of using Bugzilla for many many future development teams and even huge companies.
But OK, it probably doesn’t fit the original goals of the project anymore. :)

Comment 3

5 years ago
(In reply to Navid Zamani from comment #2)
> I thought selecting “Component: Extensions” said that.

This component is for bugs related to the way the extension mechanism works (for instance missing or broken hooks in the core code to make extensions work), not about extensions themselves.
(Reporter)

Comment 4

5 years ago
(In reply to Frédéric Buclin from comment #3)
Aaah, thanks! :)
You need to log in before you can comment on or make changes to this bug.