Closed Bug 902028 Opened 7 years ago Closed 7 years ago

[B2G][Gallery] No pictures are displayed in the gallery, only a message reading "No photos or videos, Use the Camera app to get started."

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:leo+, b2g18 verified, b2g-v1.1hd fixed)

RESOLVED FIXED
blocking-b2g leo+
Tracking Status
b2g18 --- verified
b2g-v1.1hd --- fixed

People

(Reporter: jzimbrick, Assigned: dhylands)

References

Details

(Keywords: regression, smoketest)

Attachments

(1 file)

Description:
There are no pictures displayed when the user opens the gallery, only a message reading  "No photos or videos, Use the Camera app to get started."

Repro Steps:
1. Update Buri device to 1.1 build 20130806071254. (Reproduces on com and moz rils.)
2. Take several pictures with the camera app.
3. Open the gallery app.
4. Observe that no pictures are displayed, only a message stating that the user should "Use the Camera app to get started."

Actual:
No pictures are displayed in the gallery, only a message telling the user to take pictures.

Expected:
Pictures that have been taken are displayed in the gallery app.

Environmental Variables
Build ID: 20130806071254
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a2a9b89ef5ee
Gaia: 4c1a20570e20f64782ba170c14604395c48f7381
Platform Version: 18.1
RIL Version: 01.01.00.019.180 

Notes:
Repro frequency: 100% on 2 devices, one running moz ril and the other running commercial.

Workaround: After taking a screenshot by holding home and the top button, the gallery seems to be working. However, the previously taken pictures still do not display in the gallery.
Also seems to be occurring on today's Leo and Unagi builds.
Keywords: smoketest
Summary: [B2G][Buri][Gallery] No pictures are displayed in the gallery, only a message reading "No photos or videos, Use the Camera app to get started." → [B2G][Gallery] No pictures are displayed in the gallery, only a message reading "No photos or videos, Use the Camera app to get started."
blocking-b2g: --- → leo?
Also user is unable to access music app as well getting message-> Add songs to get started "Load songs on to memory card" 
And same issue with accessing videos on a device message -> Add videos to get started "Load videos on to memory card" 
So it is sounds like general failure accessing memory card.
This issue might be related to Bug 901705 which started to happen yesterday on Unagi 1.2.
That sounds like a device storage bug.

Dave - Any ideas?
Component: Gaia::Gallery → DOM: Device Interfaces
Flags: needinfo?(dhylands)
Product: Boot2Gecko → Core
Version: unspecified → Trunk
This was a regression caused by bug 893282.

Master used webidl and 1.1 doesn't, and the change in 893282 trips on 1.1.

I have a workaround that works for 1.1. I'm just testing on master to make sure it works there.

I should have a patch landed by the end of the day.

I'm changing this to leo+ since its a regression introduced by bug 893282, which was leo+.
blocking-b2g: leo? → leo+
Flags: needinfo?(dhylands)
Blocks: 893282
Attachment #786477 - Flags: review?(dflanagan) → review+
https://bugzilla.mozilla.org/show_bug.cgi?id=902028
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
[v1-train 51f802f]
Component: DOM: Device Interfaces → Gaia
Product: Core → Boot2Gecko
Version: Trunk → unspecified
Fix is verified on Leo 1.1 commercial RIL.  Gallery, Music and Video apps now load content that is present.

Build ID: 20130807071207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/11bb1b0eefff
Gaia: 60ca81600a080dae33058b0692ecaa213556c926
Platform Version: 18.1
RIL Version: 01.01.00.019.184
Verified on Buri v1.1 Comm RIL w/ comment 9 build specs
Assignee: nobody → dhylands
Duplicate of this bug: 901479
v1.1.0hd: 51f802fdbde2f1feee95ec3a4c6a0cc8ab7657da
You need to log in before you can comment on or make changes to this bug.