Closed Bug 902051 Opened 7 years ago Closed 7 years ago

B2G NFC: Serialize/De-serialize the JSON message from nfc_worker

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 897312

People

(Reporter: allstars.chh, Assigned: allstars.chh)

References

Details

From https://bugzilla.mozilla.org/show_bug.cgi?id=674741#c154,
currently nfc_worker (in svic's github) talks to nfcd by JSON message.
And the JSON message will be defined in Bug 897312.

But this means nfcd needs to use some JSON API (in C or Cpp) to decode/encode those JSON messages.

We should define an API to serialize/de-serialize(or called marshalling) the message to some native data structure.
Assignee: nobody → allstars.chh
Bug 905109 will try to move Buf out of ril_worker, so nfc_worker can also reuse Buf.
Depends on: 905109
Blocks: 894689, 894323, 894672, 904246, 894678, 894676, 894320, 894673, 894691
No longer blocks: b2g-nfc
Depends on: 907252
Component: DOM: Device Interfaces → NFC
Product: Core → Boot2Gecko
After discussing with Yoshi, we are going to use bug 897312 to track this bug.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 897312
remove dependency on user stories.
You need to log in before you can comment on or make changes to this bug.