URL bar and search bar are nolonger in sync

RESOLVED DUPLICATE of bug 890890

Status

()

RESOLVED DUPLICATE of bug 890890
5 years ago
5 years ago

People

(Reporter: sjhiker1, Unassigned)

Tracking

23 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130730113002

Steps to reproduce:

1. Set search bar to a non-Google search provider
2. Perform search in URL bar
3. Perform search in search bar.
4. Observe that search bar and URL bar use the same search provider.


Actual results:

Search in URL bar and Search bar use the provider that is configured via the drop down box in the search bar.  If you switch providers in the search bar, it changes the provider in the URL bar.


Expected results:

Search bar and URL bar should have used different providers in keeping with the behavior in pre-23 versions.  One could configure the URL do use a single search provider (and string), while the search bar could have a different provider depending on the pull down selection.

URL bar should not change it's provider based upon Search bar selected.
(Reporter)

Updated

5 years ago
Component: Untriaged → Search
This was an intentional change - see bug 738818.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 890890
You need to log in before you can comment on or make changes to this bug.