POP msgs copied to another folder becomes the Unknown error msg, .msf file corrupted

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: esther, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Using Branch build 2001-07-10 on win (haven't tried mac or linux yet) I have a 
POP folder with 2 messages in it.  When these msgs are copied to another POP 
folder in that account when you click on the first one it displays the 2nd msg, 
when you click on the 2nd msg I get the "Unknown Error 80470002".  Reproducible 
always with the folder attached to this bug.

1. Take the attached POP folder and save it to your system.
2. Create a New Profile
3. Launch and create a POP account
4. Exit 
5. Copy the saved POP folder to the Mail account in profile you just created.
6. Launch and open Mail
7. Open the folder that you copied to the profile (you should see (2) msgs)
8. Select each message (verifying the message displays correctly)
9. Create a new POP folder
10. Multiple select both msgs in copied folder and copy the msgs to the newly 
created folder.
11. Select each of the messages that were just copied.  

Result: 1st msg displays 2nd mg content.  2nd msg gives Unknown error.
Workaround it to remove the corrupt .msf file.
(Reporter)

Comment 1

17 years ago
reassigning to navin
Assignee: sspitzer → naving
(Reporter)

Comment 2

17 years ago
Created attachment 41836 [details]
POP folder, rename and download to POP mail account
(Reporter)

Comment 3

17 years ago
nominating as nsbeta1, this may be one of the elusive POP problems reported 
frequently through newsgroups since 6.0 release
Keywords: nsbeta1
(Reporter)

Comment 4

17 years ago
Created attachment 41846 [details]
POP folder

Comment 5

17 years ago
Esther, how does this differ from 90186
(Reporter)

Comment 6

17 years ago
This was different when I logged it because with this one I was getting the
Unknown error.  With the other bug, I didn't get down the list far enough to see
the Unknown error when I logged the bug.  I mentioned this revelation in the
copy bug (90186) that I think this is the real problem.  These two messages are
part of the group of messages being copied in the other bug.  I asked Navin
about closing that bug and making this one the main bug, but he's wants to
investigate more.  
(Reporter)

Comment 7

17 years ago
Also, I confirmed this is reproducible on Mac and Linux with this test account
and the scenario.
(Assignee)

Comment 8

17 years ago
This bug also should be fixed by the fix in bug 90186
Depends on: 90186
(Assignee)

Comment 9

17 years ago
This also should be fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

17 years ago
this was fixed with trunk bug fix 90186.
trunkverified
needs to be verified on branch when fix for 90186 goes into branch
(Assignee)

Comment 11

17 years ago
*** Bug 91920 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 12

17 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.