If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Javascript menu doesn't show

VERIFIED DUPLICATE of bug 60897

Status

()

Core
JavaScript Engine
--
blocker
VERIFIED DUPLICATE of bug 60897
16 years ago
16 years ago

People

(Reporter: dge, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
If you view the page source, you can see:

<script language="JavaScript" src="bar.js" ></script>
<script language="JavaScript">
<!--
var Ibar = new bar(0);
var tempMenu;

Ibar.setSizes(1, 2, 1);
Ibar.setColors("#ffce00", "#FFFFFF", "#0000ff", "#000000", "#ff9900", "#FFFFFF",
"#0000ff", "#000000", "#FFCE00");
Ibar.setFonts("Arial, Courier New", "plain", "bold", "8pt", "Arial, Courier
New", "plain", "bold", "8pt");
Ibar.setAlign("left");

tempMenu = new Menu(90, 140);
tempMenu.addItem(new MenuItem("&nbsp;Company", "#"));
tempMenu.addItem(new MenuItem("Letter", "eng/about/letter.htm"));
tempMenu.addItem(new MenuItem("Company&nbsp;History", "eng/about/history.htm"));
tempMenu.addItem(new MenuItem("Research&nbsp;Development",
"eng/about/research.htm"));
tempMenu.addItem(new MenuItem("Customer&nbsp;Service", "eng/about/service.htm"));
tempMenu.addItem(new MenuItem("Future&nbsp;Outlook", "eng/about/future.htm"));
tempMenu.addItem(new MenuItem("Copyright&nbsp;Info", "eng/about/legal.htm"));
tempMenu.addItem(new MenuItem("Contacts", "eng/about/contact.htm"));
tempMenu.addItem(new MenuItem("Where&nbsp;to&nbsp;buy", "eng/buy/main.htm"));
tempMenu.addItem(new MenuItem("ABIT&nbsp;Newsletter", "mail.htm"));
Ibar.addMenu(tempMenu);
...

The menu shows on IE. This is the only thing prevent me to use Mozilla, because
this is only way to browse a lot of web site.
The site uses javascript which is IE-only and will not be supported by Mozilla.
 Duplicate of the evangelism bug to convince them to use the standard DOM.

*** This bug has been marked as a duplicate of 60897 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Marking Verified Duplicate - 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.