If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Thunderbird 17.0.7 crashes under Fedora 18 every time I attempt to attach a file

RESOLVED WORKSFORME

Status

Thunderbird
Untriaged
--
critical
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Graham, Unassigned)

Tracking

({crash})

17 Branch
x86_64
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 786859 [details]
Thunderbird-17.0.737a594d9-73ea-41ec-a833-22f9e2130807.html

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130624104217

Steps to reproduce:

When I upgraded to the version of Thunderbird which came with Fedora 18, I found that Thunderbird occasionally crashed when I selected a file and clicked on the Open button in the file-selector window. It seemed to depend on whether I had started to compose the email or not.
Since upgrading to the latest version of Thunderbird (yum update), Thunderbird fails on every attempt to attach a file.


Actual results:

All windows associated with Thunderbird vanished. A new window appeared notifying me of the crash, and saying that a report would be sent if I wished. I have agreed on each occasion. (You will have a lot by now)


Expected results:

The file selector window should have disappeared and the mail composition window should have shown that the file had been attached, allowing me to complete composition and then send the message.
(Reporter)

Comment 1

4 years ago
The problem is with the action to attach the file, not with sending an attachment. I am able to forward a file that already contains an attachment without problem.
(Reporter)

Comment 2

4 years ago
The problem is intermittent. Today, I have successfully attached files and sent them without problem. Yet two days ago, every attempt failed.

Comment 3

4 years ago
Try downgrading gtk2:

https://bugzilla.redhat.com/show_bug.cgi?id=971464

Comment 4

4 years ago
"yum downgrade gtk2"

Comment 5

4 years ago
Can you paste the crash id of the crash you have submitted to Mozilla?
(Reporter)

Comment 6

4 years ago
bp-37a594d9-73ea-41ec-a833-22f9e213080707/08/1320:30bp-a8b99b63-2e6b-4b02-a876-755f0213080707/08/1312:55bp-d8bb177d-5b8d-4655-a1ec-94b92213080707/08/1312:45bp-803dcd33-d220-446a-b09a-f4dcd213080707/08/1312:42bp-1a5626a2-24e6-44d7-ba6c-63ca4213080707/08/1312:33bp-63ca6013-6bb1-4d99-ad76-d41c5213080707/08/1312:23bp-8bf5a96f-1273-4636-8599-de95e213080707/08/1312:22bp-fafedf2e-1b96-441c-9da2-267f1213080707/08/1312:19
(Reporter)

Comment 7

4 years ago
I cannot copy and past from "Submitted crash reports" any neater than that. I cannot save the reports as a file, and the report ID just runs into the date submitted when I copy/paste a group of report IDs. The IDs all end in 130807

Comment 8

4 years ago
bp-37a594d9-73ea-41ec-a833-22f9e2130807
bp-a8b99b63-2e6b-4b02-a876-755f02130807
bp-d8bb177d-5b8d-4655-a1ec-94b922130807
bp-803dcd33-d220-446a-b09a-f4dcd2130807
bp-1a5626a2-24e6-44d7-ba6c-63ca42130807
bp-63ca6013-6bb1-4d99-ad76-d41c52130807
bp-8bf5a96f-1273-4636-8599-de95e2130807
bp-fafedf2e-1b96-441c-9da2-267f12130807

Yes, the crash reports show a lot of gtk libraries on the top of the stack. Can you try the downgrade suggestion?
(Reporter)

Comment 9

4 years ago
Yes, I could. However, I have not had any recurrence of the problem since 7 August. I am not sure what downgrading the gtk library would do now if the symptoms have disappeared. Would it be best for me to wait and downgrade if the problem re-occurs?

Comment 10

4 years ago
(In reply to Graham from comment #9)
> Yes, I could. However, I have not had any recurrence of the problem since 7
> August. I am not sure what downgrading the gtk library would do now if the
> symptoms have disappeared. Would it be best for me to wait and downgrade if
> the problem re-occurs?
Severity: normal → critical
Flags: needinfo?(acelists)
Keywords: crash

Comment 11

4 years ago
If you no longer see the problem then probably you have nothing to do.
May the gtk have been upgraded automatically on your system since then?
Please reopen the bug if you experience the problem again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(acelists)
Resolution: --- → WORKSFORME
(Reporter)

Comment 12

4 years ago
Thanks. There has been no recurrence of the problem. I have tried to update my system every couple of weeks. gtk has almost certainly been updated in one of those.
(Reporter)

Comment 13

4 years ago
Well after a month of trouble-free use of Thunderbird, the problem with it failing when attempting to attach a file has reappeared, happening consistently on each attempt over the last hour. I have followed your advice to downgrade gtk, and this has caused the problem to disappear.

I don't know what could have happened to trigger the failures. I haven't updated the system for a few weeks. The only thing I can think of is that I have powered my machine off and rebooted it, something that I seldom do, so possibly an update that I had earlier installed only took effect after the reboot. Today was the first time I have attempted to attach a file since the reboot.

Comment 14

4 years ago
How the hell is this on "resolved worksforme"? 

Still happens with

thunderbird-24.0-3.fc18.x86_64  on  gtk2-2.24.19-1.fc18.x86_64

Comment 15

4 years ago
(In reply to David Tonhofer from comment #14)
> How the hell is this on "resolved worksforme"? 

because the reporter had deemed it gone, and didn't reopen


> Still happens with
> 
> thunderbird-24.0-3.fc18.x86_64  on  gtk2-2.24.19-1.fc18.x86_64

do you get the same stack?
had it been determined if a specific gtk is involved?
Crash Signature: [@ libgdk-x11-2.0.so.0.2400.19@0x4239b ]
You need to log in before you can comment on or make changes to this bug.