Closed Bug 902404 Opened 7 years ago Closed 7 years ago

Windows Presentation Foundation 3.5.307291.1 Plugin isn't working with Firefox Version 23.0

Categories

(Core :: Plug-ins, defect)

23 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 872325

People

(Reporter: patrik.heim, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130729175331

Steps to reproduce:

I installed the new Version 23.0 from Version 17.07 esr to test the Windows Presentation Foundation 3.5.307291.1 Plugin. 


Actual results:

Afterwards i cannot open a XBAP WPF-Application via the Firefox. 


Expected results:

The XBAP WPF Application should be downloaded and started within the Firefox.
Could you test with a clean profile, please (it's a huge gape between ESR and FF23).
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

It that doesn't change anything, did you know if MS is aware of the issue? Did you report it?
Component: Untriaged → Plug-ins
Flags: needinfo?(patrik.heim)
Product: Firefox → Core
But I'm almost sure I saw a bug passing about this issue (XBAP WPF-Application).
Are you sure the support of this plugin is not finished (or discontinued)?
I have tested it on different maschines with new installation of FF23 and it didn't work. 
I don't know if MS is aware of that issue and i haven't reported to them.

Acording the webpage of MS http://msdn.microsoft.com/en-us/library/aa970060.aspx is Internet Expoler an Firefox supported for XBAP WPF-Applications.
Flags: needinfo?(patrik.heim)
Does it work when you go to about:config and set plugins.load_appdir_plugins to true?
Flags: needinfo?(patrik.heim)
I have changed this config parameter. Now the Plugin is shown again in Plugins Page (Tools-> Add ons), but the broswer window shows first white an after abaut 20sec it turn to black and nothing happens. Normaly it should come up the download page of the XBAP Application.
Flags: needinfo?(patrik.heim)
At least in this case we are not going to fix the bug. Microsoft needs to update their plugin to install via the registry instead of dropping into the app directory (and they may also need to fix the blackness issue, but that's separate).
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Flags: needinfo?(patrik.heim)
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 872325
Flags: needinfo?(patrik.heim)
Patrik, about the other issue (whiteness/blackness issue), there is bug 893671.
You need to log in before you can comment on or make changes to this bug.