Drag-n-drop preview of items dragged into iframe (e.g. bookmarks sidebar frame or devtools) doesn't appear until pointer exits iframe. [Dragging and dropping interaction with iframes]

NEW
Unassigned

Status

()

5 years ago
3 years ago

People

(Reporter: andrew.hayes, Unassigned)

Tracking

({reproducible, testcase})

1.0 Branch
x86
All
reproducible, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.95 Safari/537.36

Steps to reproduce:

Background:
I have an image uploader that deposits an <img> tag once uploaded.  <img> tags are dragged into a nearby tinyMCE editor where the <img> is inserted into the content.

Steps to reproduce bug:
 - move mouse pointer over <img> tag, hold down left-mouse button
 - move the mouse pointer away from the <img> tag to initiate dragging.
 - sometimes there is a slight delay between initiating dragging and the "ghost" image appearing on the mouse pointer (up to 1sec sometimes)
 - if you drag the cursor around the main page frame, the image appears on the cursor after this short delay...no problem.
 - **IF**, however, you drag the cursor over an embedded <iframe>, the "ghost" image never appears on the cursor (so in the above e.g., my <img> can't be dragged into the tinyMCE editor (which lives inside an embedded <iframe>).
 - if you keep your finger depressed on the mouse button, then drag the cursor outside the confines of the <iframe>, the ghost image magically appears (like it was waiting)...I can then drag this ghost <img> into the <iframe> tinyMCE editor as expected.

I confirmed this isn't an issue with my code or tinyMCE by reproducing the issue by dragging the <img> over a nearby <iframe> embedded google-ad...same result


Actual results:

As mentioned above, if the mouse pointer is moved over an embedded <iframe> after initiating drag, but BEFORE the ghost element appears on the mouse cursor, the ghost element will not appear until the mouse cursor leaves the vicinity of the embedded <iframe>


Expected results:

The dragged <img> (or other element) should always appear, whether the cursor is over the original page frame, or an embedded <iframe>.

Chrome has a similar delay between drag-initiation and ghost element appearance sometimes, however in Chrome, the dragged ghost element always appears on the mouse cursor regardless of which frame the mouse cursor happens to be hovering above at the time.

Alternatively, reduce the delay between drag-initiation and ghost-element appearance, which will alleviate (if not fix) the issue.
(Reporter)

Comment 1

5 years ago
This issue has been reported on Firefox 23.0 running on Mac OS X Mountain Lion.

The same bug is also confirmed as happening on Firefox 22.0 too

Not sure how far this issue goes

Comment 2

5 years ago
Provide a testcase (online or attached to this bug report), please.
Flags: needinfo?(andrew.hayes)
(Reporter)

Comment 3

5 years ago
Here you go:

http://realbuzz-stage.s3.amazonaws.com/mozilla-bug-902454/main.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(andrew.hayes)
Resolution: --- → INVALID
(Reporter)

Updated

5 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 4

5 years ago
Oops, sorry, accidentally closed the ticket

Comment 5

5 years ago
Please try to decrease "drag threshold" of OSX setting.
(I am not familiar about MAC)

Comment 6

5 years ago
Reproduced with
2004-02-10-09-firefox-i686-linux-gtk2+xft [*]
firefox-3.0a2pre.2007-01-01-04.en-US.linux-i686
firefox-3.7a1pre.2010-01-01-03.en-US.linux-x86_64
firefox-22.0.en-US.linux64 [*]
2013-08-11-03-02-25-mozilla-central-firefox-26.0a1.en-US.linux-x86_64 [*]


[*] When the image (or icon, in older builds) appears when the pointer moves out of the iframe, the image is attached to the pointer without button holding.
Keywords: reproducible, testcase
OS: Mac OS X → All

Updated

5 years ago
Summary: Dragging and dropping of <img> tags interaction with iframes → Image dragged into iframe does not appear until pointer exits iframe (Dragging and dropping of <img> tags interaction with iframes)
Version: 23 Branch → 1.0 Branch

Updated

5 years ago
Component: Untriaged → Drag and Drop
Product: Firefox → Core

Comment 7

3 years ago
>>>   My Info:   Win7_64, Nightly 47, 32bit, ID 20160212030242
I surprisingly often experience this in multiprocess mode when I drag tabs to bookmarks sidebar.
That's probably because preview lags much more in e10s mode. Non-e10s is affected too, OFC.
Anyway, I confirm everything said above (the only person who cares to set status "NEW")
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Image dragged into iframe does not appear until pointer exits iframe (Dragging and dropping of <img> tags interaction with iframes) → Drag-n-drop preview of items dragged into iframe (e.g. bookmarks sidebar frame or devtools) doesn't appear until pointer exits iframe. [Dragging and dropping interaction with iframes]
You need to log in before you can comment on or make changes to this bug.