Image carousel on twigmo.com does not work

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
4 years ago
a year ago

People

(Reporter: bug.zilla, Assigned: miketaylr)

Tracking

23 Branch
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130728 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130728030204

Steps to reproduce:

Visited http://twigmo.com/demo/cs-cart/index.php?mobile#homepage


Actual results:

All images are shown at the same time


Expected results:

Only one image should be shown with the ability to scroll through them. Works on stock and desktop.
I can't reproduce this using a Nexus 4 and Firefox for Android 26 nightly.
I cannot reproduce this on Samsung Galaxy Nexus (Android 4.1.1) and HTC Desire HD (Android 2.3.5) on latest Nightly 08/13

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

4 years ago
Still fails on a Galaxy Note.
Can anyone reproduce on this particular device?
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Can you still reproduce this issue on your device using latest Nightly?
Flags: needinfo?(bug.zilla)
(Reporter)

Comment 5

4 years ago
Yes, still there.
The correct url is now at http://cscart.twigmo.com
Flags: needinfo?(bug.zilla)
I do not see the issue you are telling, but when scrolling through the images, some flashing appears.
Tested with:
Build: 31.0a1 Nighly (2014-04-23)
Device: LG Nexus 4 (Android 4.4.2)
Kevin, is there a bug logged for this issue?
Flags: needinfo?(kbrosnan)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(kbrosnan)
Resolution: --- → WORKSFORME
Please provide a screenshot or a video to understand better the issue.
Flags: needinfo?(bug.zilla)
(Reporter)

Comment 8

4 years ago
Created attachment 8417076 [details]
Firefox screenshot
Flags: needinfo?(bug.zilla)
(Reporter)

Comment 9

4 years ago
Created attachment 8417077 [details]
Stock browser screenshot
(Reporter)

Comment 10

4 years ago
Hopefully the attached explain the issue.

In the stock browser the image carousel displays as intended (single image at a time appears as part of the image loop).

In Firefox all four images appear at the same time, "stacked" on top of each other.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
On latest Nightly using Galaxy Note GT-N7000 (Android 4.1.2) the images are displayed correctly, as in your attachment 8417077 [details].
Can you tell me your device model? Did you try on latest Nightly?
Flags: needinfo?(bug.zilla)
(Reporter)

Comment 12

3 years ago
Now on a Galaxy S4 (4.4.4) and latest Nightly.
Same problem. Thanks.
Flags: needinfo?(bug.zilla)
(Reporter)

Comment 13

3 years ago
Hi,

has there been any update to this?

Thanks
We are unable to reproduce this behavior on multiple phones. I just retested with Firefox 31 on a Nexus 5 and cannot reproduce.
Flags: needinfo?(miket)
OS: Windows 7 → Android
Hardware: x86_64 → All
Created attachment 8463403 [details]
2014-07-28 15.00.37.png

Welp, I can reproduce on my HTC One. All carousel images stacked up as one and then just blank space when it rotates to the next carousel slot. Assigning to myself to figure out why.
Assignee: nobody → miket
Status: UNCONFIRMED → NEW
Ever confirmed: true
Not seeing anything super suspicious in the source. Here's a video of a friend's OnePlus One, https://www.dropbox.com/s/bm3r149e3eccdwp/Screencast_2014-07-28-09-14-00.mp4 (which doesn't reproduce). 

@bug.zilla@mail.com, can you report back the values at http://www.quirksmode.org/m/tests/dpr.html and are you testing over wifi or data?
(Reporter)

Comment 17

3 years ago
Hi,

same problem over both wifi and data.

Is this what you're after?


device-pixel-ratio tests

This page has a <meta name="viewport" content="width=device-width">.

    Media queries for device-pixel-ratio not supported.

Checks

    screen.width equals 360.
    Layout viewport width is 980.
    Expected DPR is 0.3673469387755102.
    Reported DPR is 3.

Expected DPI is incorrect on Apple Retina devices, and on desktop browsers where the window is not completely maximised.
Flags: needinfo?(bug.zilla)
(Reporter)

Comment 18

3 years ago
Works on latest Nightly. Closing, thanks.
Status: NEW → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → INVALID
Resolution: INVALID → WORKSFORME
(Reporter)

Comment 19

3 years ago
I'm re-opening this as there seems to be a regression for the last few weeks.
Opera works fine. Thanks.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Hi, would you mind testing again? It's working for me here.
(Reporter)

Comment 21

3 years ago
Hi,

I'm on a Galaxy S4 (4.4.4) and 39.0a1.
Unfortunately I still see the stacked images.
Flags: needinfo?(bug.zilla)
(Reporter)

Comment 22

2 years ago
Works on tonight's Nightly (43.0a1 2015-09-16)
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.