Several blanks are inserted in a quotation of list

NEW
Unassigned

Status

()

defect
P3
normal
18 years ago
10 years ago

People

(Reporter: kazhik, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [have fix, need reviews])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

18 years ago
Several blanks are inserted in a quotation of list.

Steps to reproduce:

(1) Make a html mail which contains a list and save it as draft.
(2) Hit shift+Reply(or Reply) to reply the mail in plain text mode.

1. 1232. 456

This list is quoted as:

> 1.   123
> 2. 456
reassign to editor
Assignee: ducarroz → kin
Component: Composition → Editor: Core
Keywords: mailtrack
Product: MailNews → Browser
QA Contact: sheelar → sujay

Comment 2

18 years ago
There seems to be a difference in what the PlaintextSerializer writes out. When 
serializing is done based on an in memory DOM tree, the serializer 
itself drives the serializing process using recursive serializer calls to 
navigate the DOM tree, which seems to output the right thing.

In this particular case, the quoting code uses the Parser and NavDTD to control 
the serializing process, which seems to bypass some code used when serializing 
the in-memory DOM tree.
Assignee: kin → harishd
Component: Editor: Core → DOM to Text Conversion

Comment 3

18 years ago
--> peterv.
Assignee: harishd → peterv
Priority: -- → P3
Target Milestone: --- → mozilla1.1

Comment 4

17 years ago
This problem arises for the same reason as that for bug#107927. Patch for that 
bug fixes this too. 

*** This bug has been marked as a duplicate of 107927 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

16 years ago
Posted patch patch v0.1 (obsolete) — Splinter Review
The current code inserts a blank at the beginning of the list item.
What is that for? The quotation of list item works fine if I remove
that code.
(Reporter)

Comment 7

16 years ago
I think this bug is nothing to do with bug 107927.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 8

16 years ago
Posted patch patch v0.1 (obsolete) — Splinter Review
The previous attachment was wrong.
Attachment #123751 - Attachment is obsolete: true
I doubt that that's the right fix. Won't this break copying a word with a space
in front of it? After your patch we will just be dropping the space in front of
the selected word which is not what we want.
(Reporter)

Comment 10

16 years ago
Posted patch patch v0.2Splinter Review
Thank you for the comment, peterv.
I updated the patch to output spaces when copying text from web page
to mail editor.
Attachment #123752 - Attachment is obsolete: true
Clearing milestone since 1.1 is long since gone. We have quite a bit of copy &
paste work lately, so I was wondering is this bug is still happening?
Whiteboard: [have fix, need reviews]
Target Milestone: mozilla1.1alpha → ---
Assignee: peterv → dom-to-text
Status: REOPENED → NEW
Assignee: dom-to-text → nobody
QA Contact: sujay → dom-to-text
You need to log in before you can comment on or make changes to this bug.