[meta] Week view: header with two months is shown truncated in multiple locales

RESOLVED FIXED

Status

Firefox OS
Gaia::Calendar
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: delphine, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug, {l12y})

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g18 affected)

Details

Opened up this bug to track other instances in v1.1, since it very often happens that in Week view, the header with two months is shown truncated

We have asked localizers to find workarounds when possible for this (following UX l10n Recommendations), however this is not a long term solution. 

Issue found in: Croatian, Hungarian, Turkish
status-b2g18: --- → affected

Comment 1

4 years ago
This issue also occurs in Greek language, Combined months in week tab with longer strings are truncated for example "Αύγ/Σεπτέμβριος...

Environmental Variables
Build ID: 20130807071207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/11bb1b0eefff
Gaia: 60ca81600a080dae33058b0692ecaa213556c926
Platform Version: 18.1
Depends on: 933682

Updated

4 years ago
Duplicate of this bug: 978322
Blocks: 978219
Blocks: 978298
Blocks: 978209
Blocks: 978169
Blocks: 978351
Blocks: 978344
Blocks: 978332
Blocks: 978326
No longer blocks: 978169, 978209, 978219, 978298, 978326, 978332, 978344, 978351

Comment 3

4 years ago
As this also occurs in English (including 1.2, 1.3), I’d say it has nothing to do with l10n.

The issue could probably be solved by either using abbreviated month names (perhaps only when needed), or awaiting the outcome of bug 908300.
Depends on: 977873, 978166, 978214, 978315, 978359
Right now when there are two months in week view the result comes from the concatenation of these l10n ids: single-month-view-header-format, month-view-header-format

So, a solution could be to keep month-view-header-format id for month view and one-month week view and having a separate id for the case of two-week week view.

However, I am not sure if this solution of removing the concatenation and having separate ids is easy to be done.


(In reply to Ton from comment #3)
> As this also occurs in English (including 1.2, 1.3), I’d say it has nothing
> to do with l10n.
> 
> The issue could probably be solved by either using abbreviated month names
> (perhaps only when needed), or awaiting the outcome of bug 908300.
I mean two-month, no two-week, in the previous comment.

Also one more comment, abbreviated month names will affect also the month view header as it depends on month-view-header-format.
Duplicate of this bug: 978304
Duplicate of this bug: 978335
Marking this as fixed.

In 2.0+ we resize headers to fit (bug 908300). Also, header now uses short month names (bug 803238).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.