Closed Bug 902597 Opened 6 years ago Closed 6 years ago

"check for updates" does not honor "ask me what to do"

Categories

(Thunderbird :: Untriaged, defect)

17 Branch
x86_64
Windows 8
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 707489

People

(Reporter: educmale, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130730113002

Steps to reproduce:

Manually clicked on the "Check for Updates" button on the about TBird dialog

My TBird is set to check automatically for updates, but I also set the "ask me what to do" button


Actual results:

It checks.
Then, without my consent, it:  a) downloads the update, and then b) applies (attempts to apply) that update.


Expected results:

The button should honor my choices about asking me what to do if an update is found.

Alternatively, and though I do -not- agree with this UI:  the button should be rewritten to reflect what it is about to do, ie: check and if an update is found, to automatically and without further user intervention, download and install.

Really, that the button says: "Check for updates", it should do just, and only that.

An improved UI should have a -second- button which reads: "Check and apply all updates automatically"
I am sure this is reported somewhere, maybe for Firefox too.
Whiteboard: [DUPEME]
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: [DUPEME]
Duplicate of bug: 707489
You're correct....my recheck on filing this shows at least 

TBird: 
Bug 707489

Fox: 
Bug 600500, appears to have a fix in progress?
Bug 690964, was reopened 2012-11-06
You need to log in before you can comment on or make changes to this bug.