"Cached Web Content" and "Offline Web Content and User Data" should be in the Privacy tab

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
RESOLVED WORKSFORME
4 years ago
17 days ago

People

(Reporter: Carl Menezes, Unassigned)

Tracking

22 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

I want to wipe Firefox's memory to test an internal site.
I went to Privacy and cleared everything.


Actual results:

This did not clear everything.
I had to go into Advanced > Network to find the Cached Web Content and Offline Web Content entries and clear them.


Expected results:

These entries should have been in the Privacy tab. 
Since they also contains records of my browsing activities, if I want to clear all traces, I should be able to find everything I need in the Privacy tab. 

A side issue is that I should also be able to clear everything in Firefox's "memory" with regard to a specific site from the Privacy tab. 

To clarify, I believe this to be a usability issue. How is a novice internet user supposed to know that traces of their browsing activity is still on disk because they have not looked in the Advanced > Network tab?
Status: UNCONFIRMED → NEW
Component: Untriaged → Preferences
Ever confirmed: true
They are now!
Status: NEW → RESOLVED
Last Resolved: 17 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.