[Application Manager] After Uninstalling the Userapp from App manager, it shows different behavior for different apps

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: swaroopa, Assigned: Amelie Kong)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [POVB])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 787220 [details]
AppManager2.png

STR:

1. Install an app from the Market Place. Ex Facebook. Log in and ensure that some user data is generated.
2. Goto Settings > App Manager > User Apps and Click on the app. From the App info page, click on Uninstall Button.

Actual Behavior:
I Noticed 2 behaviors here at different times:
Case 1:
The app is uninstalled but the user still stays on the App info screen. 'Stop' and 'Uninstall' buttons are disabled. But one of the 2 'Clear' buttons are enabled and when clicking on it nothing happens. (Attached screenshot for 'Pathuku' app)

Case 2: 
After clicking on Uninstall the user is navigated automatically to the Settings > App permission page. 

Expected Behavior: 
The user should be navigated to the list of apps screen in App Manager after uninstalling. Should not stay on the App info screen or navigate to the App permissions screen.
(Reporter)

Comment 1

4 years ago
Gaia   b824d770f590b1e1886fa55bbf273d26c10dd525
BuildID 20130731163341
Version 18.0
Blocks: 902953
Assignee: nobody → mei.kong
POVB since this only affects the Buri app manager on their device specifically.
Whiteboard: [POVB]
blocking-b2g: leo? → koi?

Comment 3

4 years ago
This bug is fixed on Buri code.
Closing per comment 3
Status: NEW → RESOLVED
blocking-b2g: koi? → ---
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.