Closed Bug 902719 Opened 7 years ago Closed 7 years ago

Keep getting "package invalid" error on multiple update, reinstall attempts via Google Play.

Categories

(Firefox for Android :: General, defect)

23 Branch
Other
Linux
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: s__anderson, Unassigned)

Details

User Agent: Mozilla/5.0 (Linux; Android 4.1.2; Xoom Build/JZO54M) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.94 Safari/537.36

Steps to reproduce:

Automatic update called through Google Play. Firefox update repeated several times through the day.

NOTE: I'm guessing about the version number I had when FF was trying to update. I know my PC FF version number but hadn't checked or kept up with the FF Android version because it was updating automatically. I can't check it now because I uninstalled FF (see below).


Actual results:

Every download included error symbol in notification bar. When I looked into that, the message was "package invalid" or "invalid package."  The error message gives no indication what package is invalid, so I assume it's the FF update package.

BTW, when I started my Motorola Xoom (10.1 inch) today, I got a notification it had updated to Android 4.1.2 (IIRC).


Expected results:

What I've been hoping for was a successful update that would put an end to the increasingly frequent freezes and crashes I've been been experiencing with FF Android since about June, at least. I love Firefox and have for years, but on Android the relationship is in serious trouble.

I finally uninstalled FF today. The next time I cold boot the tablet I'll try a fresh install and see if that does any better.
I'm seeing a bunch of comments to the same effect, reported with tablets with time stamps that align with Fx23 GA (08/06): 

*Asus TF101 This used to work, but on the latest update I received an "invalid package" error. I tried uninstalling it then reinstalling it, that didn't work. Looks like no more Firefox for my tablet. 

*'Package File Is Invalid' Blues I tried to update the app on my GNote2, but it said, "package file is invalid". So I tried uninstalling and reinstalling, but I still got the error, "invalid package file" near the end of the install. So now I can't install Firefox at all. I was able to restore the app with my Titanium Backup, but I still can't update it. Current version is 22. 

*Won't install Wish I could give this all stars, but it won't install. Error message says invalid. Please fix, I love Firefox


*Update to V.23 fails on android tablet. "Package file is invalid". Anyone else see this?
Version: Firefox 22 → Firefox 23
Keywords: qawanted
I have this issue while being on Google Play 4.3.11. This should be reopened.
We don't have any control over the way Google Play delivers our APK to devices. I suggest restarting your device or retrying when Google Play is not in the middle of a massive update.

If the issue does not go away with a restart try contacting Google directly at https://support.google.com/googleplay/?rd=1#contact=1 assuming that your issue is not listed on https://support.google.com/googleplay/known-issues/1319135
I actually realized that I had 0.2 GB of system storage left. Freeing more 0.1 GB allowed correct installation. I reported the problem to Google. Thanks!
You need to log in before you can comment on or make changes to this bug.