Closed Bug 902797 Opened 9 years ago Closed 9 years ago

[meta] B2G RIL: Support RIL version 8

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: allstars.chh, Unassigned)

References

Details

From Android 4.3, the version of RIL is using v8.

This bug is filed as a meta bug to tracking efforts need to be done for RIL v8.
Component: DOM: Device Interfaces → RIL
Product: Core → Boot2Gecko
Version: Trunk → unspecified
There are no bugs being tracked here. What do we need to add support for?
No longer blocks: gonk-jb
Depends on: gonk-jb
(In reply to Michael Wu [:mwu] from comment #1)
> There are no bugs being tracked here. What do we need to add support for?

I spotted JB4.3 uses RIL v8 so filed this bug.
And rild has backward compatibility so RIL v6 can run well on this version.
Currently no bugs has been found yet.
(But only a few people uses Nexus-4 but they are not testing RIL).

If you think we should close this bug until we met problem, please feel free to do it.
I see. Let's just leave this bug then. I've made it not block gonk-jb.

I've heard of people using telephony successfully on the N4, though it's probably not that thoroughly tested.
This bug had been fixed with https://github.com/mozilla-b2g/platform_hardware_ril/commit/8f68263d1c5c06c77a5af1ca42b59584da3692a0
We've been using RILv8 in b2g-jellybean branch since then.  All RIL test cases are working (but bug 933654).
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.