Closed Bug 902878 Opened 6 years ago Closed 6 years ago

[unagi] crash on abort in mozilla::layers::PGrallocBuffer::Transition

Categories

(Core :: Graphics: Layers, defect, critical)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
blocking-b2g koi+

People

(Reporter: Bebe, Unassigned)

References

Details

(5 keywords, Whiteboard: [b2g-crash])

Crash Data

Attachments

(1 file)

Attached file logcat of the issue
This bug was filed from the Socorro interface and is 
report bp-487a37bf-b473-4522-b716-685a42130808 .
 ============================================================= 

The camera app crashes when trying to change source  

STR:
1. Open the camera app
2. Tap the video icon to switch source

Expected:
2. The user should be able to record videos

Actual:
2. The camera app crashes


Gecko  http://hg.mozilla.org/mozilla-central/rev/79b5c74ef97b
Gaia  43557e5392ab37d4f8c1fa08184cf1541b249a54
BuildID 20130807161117
Version 26.0a1
Keywords: unagi
Summary: crash in mozalloc_abort(char const*) | NS_DebugBreak | mozilla::layers::PGrallocBuffer::Transition(mozilla::layers::PGrallocBuffer::State, mozilla::ipc::Trigger, mozilla::layers::PGrallocBuffer::State*) → [unagi] crash in mozalloc_abort(char const*) | NS_DebugBreak | mozilla::layers::PGrallocBuffer::Transition(mozilla::layers::PGrallocBuffer::State, mozilla::ipc::Trigger, mozilla::layers::PGrallocBuffer::State*)
Component: Gaia::Camera → General
Summary: [unagi] crash in mozalloc_abort(char const*) | NS_DebugBreak | mozilla::layers::PGrallocBuffer::Transition(mozilla::layers::PGrallocBuffer::State, mozilla::ipc::Trigger, mozilla::layers::PGrallocBuffer::State*) → [unagi] crash on abort in mozilla::layers::PGrallocBuffer::Transition
Whiteboard: [b2g-crash]
Component: General → Graphics: Layers
Product: Boot2Gecko → Core
Summary: [unagi] crash on abort in mozilla::layers::PGrallocBuffer::Transition → [unagi] crash in mozalloc_abort(char const*) | NS_DebugBreak | mozilla::layers::PGrallocBuffer::Transition(mozilla::layers::PGrallocBuffer::State, mozilla::ipc::Trigger, mozilla::layers::PGrallocBuffer::State*)
Whiteboard: [b2g-crash]
Version: unspecified → Trunk
Summary: [unagi] crash in mozalloc_abort(char const*) | NS_DebugBreak | mozilla::layers::PGrallocBuffer::Transition(mozilla::layers::PGrallocBuffer::State, mozilla::ipc::Trigger, mozilla::layers::PGrallocBuffer::State*) → [unagi] crash on abort in mozilla::layers::PGrallocBuffer::Transition
Whiteboard: [b2g-crash]
Apparently the fix to bug 900012 didn't cover this.
(In reply to Milan Sreckovic [:milan] from comment #1)
> Apparently the fix to bug 900012 didn't cover this.

It was fixed for a few days but regressed today :(

I know because we have been enabling and disabling the ui tests affected by it depending on their pass/fail state.
That's a great info :zac, thanks!  Probably dupe or the same issue as bug 902927.
blocking-b2g: --- → koi?
(In reply to Milan Sreckovic [:milan] from comment #3)
> That's a great info :zac, thanks!  Probably dupe or the same issue as bug
> 902927.

Should we dupe this out already, or investigate separately? Nobody is working on bug 902927, and this is a smoketest blocker.
Flags: needinfo?(milan)
Blocks: GFXB2G1.2
Flags: needinfo?(milan)
I can't reproduce this bug on buri with patches from Bug 907745 (in inbound at the moment)
QA Wanted - when the patches on inbound on bug 907745 land on central with a build available, retest this.
Keywords: qawanted
QA Contact: mozillamarcia.knous
(In reply to Nicolas Silva [:nical] from comment #6)
> I can't reproduce this bug on buri with patches from Bug 907745 (in inbound
> at the moment)

Looks like the bug indicates that the patch was preffed off on landing. Removing qawanted - we should test this when that lands preffed on.
Keywords: qawanted
This is no longer reproducible in today's build:
Gecko  http://hg.mozilla.org/mozilla-central/rev/d54e0cce6c17
Gaia  c6d58088f207829d96e7bb33ddacf990e90752fb
BuildID 20130903040204
Version 26.0a1
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
No longer blocks: GFXB2G1.2
blocking-b2g: koi? → koi+
You need to log in before you can comment on or make changes to this bug.