elpais.com/m/elpais/videos can’t play a video

RESOLVED WORKSFORME

Status

Tech Evangelism
Mobile
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: efrat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.95 Safari/537.36

Steps to reproduce:

Browsed to "http://elpais.com/m/elpais/videos.html" from Gaia browser

Tested on: 
User Agent String: Mozilla/5.0 (Mobile; rv:26.0) Gecko/26.0 Firefox/26.0

Model: nice
Software: Boot2Gecko 1.2.0.0-prerelease
Platform Version: 26.0a1
Build identifier: 20130807023701
Update channel: default


Actual results:

The site loads but browser is stuck and cannot play video



Expected results:

The web page should have been displayed correctly for mobile 
Displays correctly on Firefox for Android and Chrome for Android
(Reporter)

Updated

5 years ago
Component: Gaia::Browser → Mobile
Product: Boot2Gecko → Tech Evangelism
Video now plays, but they have some very odd JS running only for moz that adds target="_blank" attributes to javascript: links by mistake. We end up with

<div class="compartir_video"><a tabindex="19" target="_blank" href="javascript:void(0);" onclick="javascript:window.open('http://eskup.elpais.com/todos.html?m=+'+tit+'+-+'+encodeURIComponent(_url_vid_1377759688));" title="Enviar vídeo a Eskup">Enviar vídeo</a></div>

and

	<a tabindex="20" target="_blank" class="posicionador" id="posicionador_1377758184_726257_1377857041" title="Ver vídeo" href="javascript:void(0)">
		<span class="boton_video"></span>

This issue is reported as bug 911150. The video does play for me in FirefoxOS 1.1, closing as WFM - could someone verify?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
After the blank tab opens and I go back to videos.html, I see a message "Video can't be played because the file is corrupt."

Not sure if it's a temporary glitch or what.
(Hmm... it doesn't. "No video with supported format and MIME type found." That sounds wrong.)
You need to log in before you can comment on or make changes to this bug.