Flash plugins are displayed larger then they should on Gingerbread devices

VERIFIED FIXED in Firefox 25

Status

()

Firefox for Android
Plugins
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: AdrianT, Assigned: kats)

Tracking

({regression})

Trunk
Firefox 26
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox24 unaffected, firefox25+ verified, firefox26+ verified, fennec25+)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 787472 [details]
screenshot

Aurora 25.0a2 2013-08-08/ Nightly 26.0a1 2013-08-08
HTC Desire HD (Android 2.3.5)

Steps to reproduce:
1) Open a website with some flash content(for e.g. intel.com/museumofme or http://people.mozilla.org/~mwargers/tests/flash/flashembed.html)
2) Tap to activate the plugin

Expected results:
The flash plugin is displayed the correct size.

Actual results:
Besides being mispositioned (bug 869368) it is also larger then it should
(Reporter)

Comment 1

5 years ago
Also the taps are registered wrong - see http://neave.com/tic-tac-toe - the tap will add the X or O in the wrong position.
This may have been caused by bug 803207, can we get a regression window to verify?
Keywords: regressionwindow-wanted
may be related to bug 900592
Assignee: nobody → matt.woodrow
tracking-fennec: ? → 25+
The regression window is:

mozilla-central
good build: 04.07.2013 
bad build: 05.07.2013 
-pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dcbbfcdf7bb4&tochange=17fe59f6c54a
Keywords: regressionwindow-wanted
Bug 803207? Bug 866265?
Flags: needinfo?(bugmail.mozilla)
Assignee: matt.woodrow → bugmail.mozilla
Blocks: 803207
Flags: needinfo?(bugmail.mozilla)
Adrian, can you test with the above try build to see if it is still a problem?
Flags: needinfo?(adrian.tamas)
(Reporter)

Comment 8

5 years ago
Tested the trybuild on the HTC Desire HD (Android 2.3.5). Bug 869368 is still reproducible but the issue in this bug has been fixed. Playback works as it should with the plugins set to "Tap to play" or "Enable". I also can't see any regressions from this on an LG Nexus 4 (Android 4.1.1). The fix looks good.
Flags: needinfo?(adrian.tamas)
Awesome, thanks for the quick turnaround!
Attachment #788932 - Flags: review?(snorp)
Comment on attachment 788932 [details] [diff] [review]
Patch

Review of attachment 788932 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, though I am not really sure I understand the new LayoutDeviceRect stuff.
Attachment #788932 - Flags: review?(snorp) → review+
Attachment #788932 - Attachment description: Patch (untested) → Patch
https://hg.mozilla.org/mozilla-central/rev/4b8ffeac11d3
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Comment on attachment 788932 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 803207
User impact if declined: plugins are sized incorrectly on pre-honeycomb hidpi devices
Testing completed (on m-c, etc.): via AdrianT. This should probably bake a few days and be verified on m-c before uplifting
Risk to taking this patch (and alternatives if risky): fairly low risk
String or IDL/UUID changes made by this patch: none
Attachment #788932 - Flags: approval-mozilla-aurora?
status-firefox26: affected → fixed

Comment 14

5 years ago
Verified this bug on:
Device: LG Nexus 4 (Android 4.2.2)
Build: Nightly 26.0a1 (2013-08-14)
status-firefox26: fixed → verified

Updated

5 years ago
tracking-firefox25: --- → +
tracking-firefox26: --- → +

Updated

5 years ago
Attachment #788932 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on:
Build: Firefox for Android 25.0a2 (2013-08-27)
Device: HTC Desire HD 
OS: Android 2.3.5
Status: RESOLVED → VERIFIED
status-firefox25: fixed → verified
You need to log in before you can comment on or make changes to this bug.