DevTools: Inspector Buttons should indicate graphically the final DOM node

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Inspector
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: sys.sgx, Unassigned)

Tracking

26 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 787512 [details]
image1.png

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130808030205

Steps to reproduce:

Do exactly as described sequentially:

1. Browse to https://bugzilla.mozilla.org/enter_bug.cgi
2. Right click somewhere in the clear area of the page, and click inspect element to open the Inspector Panel.
3. In the Inspector Panel keep pressing the "right" button (next to the search input) so that the DOM nodes will be shown.
4. The Inspector for some reason does not recognize is should "enclose" the final element visually as it should, thus resulting to the image 1 attached.

Also, even on image 2, where there is no other nested element, the Inspector does not clearly show this.

On image 3, it is shown how the two cases above should be done.



Expected results:

The Inspector should clearly show the final element.
(Reporter)

Updated

5 years ago
Component: Untriaged → Developer Tools: Inspector
OS: Windows Vista → All
Hardware: x86 → All
(Reporter)

Comment 1

5 years ago
Created attachment 787513 [details]
image2.png
(Reporter)

Comment 2

5 years ago
Created attachment 787514 [details]
image3.png
Blocks: 592320

Comment 3

5 years ago
This is probably a regression due to the new breadcrumbs widget.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.