text-indent: (percentage); with certain css combinations causes table misrender.

RESOLVED FIXED

Status

()

Core
Layout: Tables
--
major
RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: dylang, Assigned: Alexandru Savulov)

Tracking

({css2, regression, testcase})

Trunk
css2, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Compare:
http://web.thock.com/mozilla/nbsp_bug1.html
http://web.thock.com/mozilla/nbsp_bug2.html

The difference?  <p>&nbsp;</p> inside the same td that has a sub-table for story
title/story intro.  It somehow eats the next cell entirely!

&nbsp; eating a table cell is sorta big, IMO :/
(Reporter)

Comment 1

17 years ago
Oh, forgot to mention this affects 2001070521 and 2001071021.
Summary: &nbsp; causes table misrender. → &nbsp; causes table misrender.

Comment 2

17 years ago
The page even breaks in IE, but in a different way.
Confirmed Win2K/2001070904
Are you sure that it is a &nbsp; issue?  Looks more like a <p> issue, especially
if its related to the other bug your reported (bug 90300).
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 3

17 years ago
Yeah, IE misrenders a lot of things for no good reason.  It can't handle the
nested table that Mozilla fixed its problems with in bug 25707, even though
every other browser (Lynx, Konq, NS4, iCab, Opera, MacIE) flows the table width
fine.

The Mozilla bug is a really weird one, because that page worked a month ago.  I
don't know what changes caused the misrendering to occur.

Comment 4

17 years ago
Created attachment 43949 [details]
Testcase

Comment 5

17 years ago
It's the style for the <p> that makes the table go out of wack:
  p { text-indent: 5%; white-space: pre } 
Keywords: testcase

Comment 6

17 years ago
Reassigning to alexsavulov to determine if it is a block or table issue.
Assignee: karnaze → alexsavulov
Keywords: css2

Comment 7

16 years ago
WFM 2001/12/25 Linux 20011222 build.

Comment 8

16 years ago
wfm? build 2002030208 trunk win32

Comment 9

16 years ago
WFM 2002030403/WinXP
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 10

16 years ago
reporter if you are still seeing this in a recent build please reopen
REOPEN. The reason why the reported URLs are working is that the CSS file used,
"http://thock.com/test/?op=css;type=group;css=mainpage", is no longer present.
If you change that to the stylesheet the main page on the site uses,
"http://web.thock.com/style.css" you will see that the bug is still present.
In "http://web.thock.com/style.css" there is a rule that says:
P {
	text-indent: 5%;
	font-family: gill, helvetica, sans-serif;
	text-decoration: none; 
	background: transparent;
	margin-left: 1%;
	margin-right: 1%;
}

and it is the "text-indent: 5%" that is causing the bad cell sizing.

Much as my testcase have shown all along, BTW.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 12

16 years ago
adding regression keyword from bug 90300
changing summary to the real problem
these 'certain css combinations' might only be the presence of text-decoration,
but I'll have to check.
Keywords: mozilla1.0, regression
Summary: &nbsp; causes table misrender. → text-indent: (percentage); with certain css combinations causes table misrender.

Comment 13

16 years ago
*** Bug 90300 has been marked as a duplicate of this bug. ***
The checkin for bug 130116 may have helped this some.  However, it still looks
like something is taking 5% of NS_UNCONSTRAINEDSIZE.

Comment 15

16 years ago
the patch in bug 148240 will fix the testcase
Depends on: 148240

Comment 16

16 years ago
fixed tested with 2002060408 win98
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.