If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Major table regression! Table reflow broken on previously working pages.

VERIFIED DUPLICATE of bug 90297

Status

()

Core
Layout
--
major
VERIFIED DUPLICATE of bug 90297
16 years ago
4 years ago

People

(Reporter: dylang, Assigned: Marc Attinasi)

Tracking

({regression, testcase})

Trunk
mozilla1.1alpha
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [awd:tbl], URL)

Attachments

(4 attachments)

(Reporter)

Description

16 years ago
On build ID 2001070521, 2001071021, and 2001060703, the 

See also 
http://web.thock.com/mozilla/table_reflowa.html, which passed XHTML 1 strict and
CSS validation.

This was a rather unfun shock since I designed the layout using Moz (which, in
May/June, rendered these fine).  Konq does a decent rendering of it (it does not
honour table attributes, the em padding, and has redraw issues, though).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

16 years ago
Seeing on Win2K/2001070904
OS: Linux → All
Hardware: PC → All

Comment 2

16 years ago
Could you attach the testcase to the bug, the host is unreachable for me -> no
triage.
(Reporter)

Comment 3

16 years ago
Created attachment 41975 [details]
Misrendered article.
(Reporter)

Comment 4

16 years ago
Created attachment 41976 [details]
Another misrendered article.
(Reporter)

Comment 5

16 years ago
So first we have the table, which has "padding-right: 10em;" applied.  No width
is specified.  But somehow it ends up being really wide (3-4 screens), and not
showing any text.  The floating banner css also seems to have been broken, in
that it's no longer centred (could be an affect of the table problems).

The floaty is copied from http://www.w3.org/Style/CSS/, where it works fine in
2001070521.  This makes me think that the one table problem is causing others
which aren't directly related.
(Reporter)

Comment 6

16 years ago
Ohh, a new facit to this bug.

Head to http://thock.com/test/?op=story;sid=140920008782

You'll see it doesn't misrender.  Why?  I suspect it has to do with the <pre>
used in the other article.  Why is the pre rendering broken?
Keywords: regression

Comment 7

16 years ago
Created attachment 49208 [details]
Simplified version of the first testcase

Comment 8

16 years ago
I added a simpler testcase (#49208) of the first page. It appears to be some
combination
of <p> rules, table rendering, "text-indent" and "white-space: pre". (The
problem with the table being too wide is not a bug at all, I'd guess -- it's
only how things should be when you haven't specified a table width and are using
"white-space: pre". The testcase does NOT expose this "bug"/problem.)
Keywords: testcase

Comment 9

16 years ago
problem still there.
Whiteboard: [awd:tbl]

Updated

16 years ago
Keywords: mozilla0.9.9
Set milestone to Moz1.1
Target Milestone: --- → mozilla1.1

Comment 11

16 years ago
Created attachment 69958 [details]
debug log

Comment 12

16 years ago
The problem occurs with
  - *percentage* text-indent
  - nowrap or pre

-moz-pre-wrap doesn't trigger this bug.
It has nothing to do with paragraph rules, because the same thing happens with 
<div>.

If you put white-space: nowrap instead of white-space: pre, putting the text 
directly in the td does cause the first line to render. But if you use 
white-space: pre, it does.

The regression seems to have taken place before 2001-05-31.

Comment 13

16 years ago
As visible from the debug log for the previous testcase the line layout is
completely wrong. Once the line-layout bug shown by the debug reflow is fixed,
it would be good to verify that no table bug was hidden here. This is yours Marc.
Assignee: karnaze → attinasi
Component: HTMLTables → Layout

Comment 14

16 years ago
Based on the source in 90297, I think these are the same bug.  Marking as such.

Comment 15

16 years ago

*** This bug has been marked as a duplicate of 90297 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 16

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.