V.1.1 User Experience Polish

RESOLVED INVALID

Status

Firefox OS
Gaia::Everything.me
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: patryk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 787730 [details]
emev11polish.png

Attached is a screenshot outlining the issues. There is a strange interaction behave, if I swipe away from my results to the app grid and then return, my results get wiped, they probably shouldn't
Patryk, we landed a new version 2 hours ago in the master branch (v1-train merge is still pending approval) and it fixes many issues.
In my Unagi device with the latest Gaia master, the swiping performance is good, the "Enter any topic.." text is clearer and the + image is crisp.

What device are you testing on? And is it the latest Gaia master?
(Reporter)

Comment 2

5 years ago
Created attachment 788171 [details]
2013-08-09-10-49-51.png

Just loaded today's build. https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-b2g18-unagi/latest/

Still see all the issues listed. Will test with tomorrow's build.

I noticed one new issue, see attached.
I am offline, I searched for "rihanna", looks like a page has loaded however I didn't get any notification stating I should be online.
(Reporter)

Comment 3

5 years ago
Created attachment 788173 [details]
2013-08-09-10-49-17.png

Noticed this dialog on 2013.08.09 1.1 builds. 
A) its not a common control
B) it seems like overkill, we give the user a hint in the search field, and then there's another caption below the search field stating what to do... do we really need a 3rd hint? If so, we should probably rethink the search box, since users should know what to do.
(Reporter)

Comment 4

5 years ago
(In reply to Ran Ben Aharon (Everything.me) from comment #1)
> What device are you testing on? And is it the latest Gaia master?
Testing on an unagi, the swiping performance seems to be fixed on todays build but I found 2 new issues, see about.
(Reporter)

Updated

5 years ago
Flags: needinfo?(ran)
Regarding the hints - totally agree. All hints have been removed on master but denied for leo. https://bugzilla.mozilla.org/show_bug.cgi?id=879292. I'd love to see it land on leo.

Regarding the connectivity message - can't reproduce. I do get the message when offline.
I can't access the nightly builds so I can't know which version you're currently testing :/
Flags: needinfo?(ran)

Updated

5 years ago
Flags: needinfo?(padamczyk)
(Reporter)

Comment 6

5 years ago
> Regarding the connectivity message - can't reproduce. I do get the message
> when offline.

I can't seem to replicate that on Oct 28 v1.2 build anymore, so perhaps it has been resolved.
Flags: needinfo?(padamczyk)

Comment 7

5 years ago
There is a known issue about missing offline message on new devices
Depends on: 932248
Patryk, you can go ahead and resolve this Bug.
The fix for the connection message wasn't approved for 1.2 but is nominated for 1.3.

Comment 9

5 years ago
ok to close?
Flags: needinfo?(padamczyk)
(Reporter)

Comment 10

5 years ago
Yes I believe we addressed all these issues in v.1.2 and v.1.3.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(padamczyk)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.