unexplainable 404 error for edge case popcorn project

RESOLVED FIXED

Status

Webmaker
webmaker.org
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jacob, Assigned: jbuck)

Tracking

Details

(Reporter)

Description

5 years ago
This popcorn URL from jamiebelido delivers a 404

https://jamiebeldio.makes.org/popcorn/1aqw

but it shows up in search

https://webmaker.org/en-US/search?type=user&q=jamiebeldio

So not sure what's causing it because it doesn't appear the project was deleted.

Also, out of curiosity, what happens when a project is deleted? Does the URL become a 404 or does it redirect? Should we file a bug to provide a unique page that says "it appears this person has deleted their project, sorry"
(Reporter)

Comment 1

5 years ago
two more 404's her

This one:

https://soerenmadsen9.makes.org/popcorn/1ahe
https://webmaker.org/en-US/search?type=user&q=soerenmadsen9

"Visiting Europe" shows up in the search but delivers a 404


This one is a 404

https://1902.makes.org/popcorn/1afk

but in this case user 1902 doesn't exist so can't locate anything in search
Confirmed. This might be a webmaker.org bug.
Component: Popcorn Maker → webmaker.org
(Assignee)

Comment 3

5 years ago
I'll take a peek at this
Assignee: nobody → jon
Status: NEW → ASSIGNED
(Assignee)

Comment 4

5 years ago
The 1902 user bug was a user id/user name; I don't know what's up with the other makes though. It looks like that data wasn't even published to S3? Weird...
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.