All users were logged out of Bugzilla on October 13th, 2018

[B2G][Helix][MMS][zhaotao]received vcf file was shown as text,can not import to contacts

VERIFIED FIXED

Status

P2
blocker
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: lecky.wanglei, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; aff-kingsoft-ciba; Zune 4.7)

Steps to reproduce:

1.use an android phone,send a mms with vcf attachment file to ffos phone
2.check the ffos phone to view the received mms


Actual results:

vcf file content showed as text,i can not imported the vcf to contacts


Expected results:

the vcf file should be shown as a link,when i click it,vcf file content can be imported to contacts
(Reporter)

Updated

5 years ago
Priority: -- → P2
(Reporter)

Updated

5 years ago
Summary: [B2G][Helix][MMS]received vcf file was shown as text,can not import to contacts → [B2G][Helix][MMS][zhaotao]received vcf file was shown as text,can not import to contacts
Wilfred, is this something to backlog in comms?
Flags: needinfo?(wmathanaraj)
(Reporter)

Updated

5 years ago
blocking-b2g: --- → hd?

Comment 2

5 years ago
Let me explain the issue per my understanding from our in face-to-fact meeting with lecky.

The problem can be separated into two parts:
1. a received vcf file (from mms or bluetooth file transfer, or even a hard copy by mounting sdcard) may be in unsupported format. In this case, if the user trying to import contacts from sdcard:
- [Actual result]
  the loop seems break when seeing an unsupported formate vcf, so the following vcf files won't be parsed.
- [Expected result]
skip the vcf file and keep importing contacts from the rest supported format files.

2. support more different vcf format: I will suggest open another issue for this issue.
(Reporter)

Updated

5 years ago
Severity: normal → blocker

Comment 3

5 years ago
Marked it as "NEW" since it was a bug.

Also, submitting a related bug (914095)
Thank you.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

5 years ago
Just a quick update.
The second problem has been solved. You can refer to Bug 910164.
The patch has landed on V1-TRAIN. I will test the patch later and request to uplift it to V1.1.0 hd if I don't find any side effect.
Thank you.


-------- Needinfo myself to remember this case ---------
Flags: needinfo?(whsu)
no vcard or vcal support from MMS in v1.2; this should be a feature request for v1.3 or beyond.
Flags: needinfo?(wmathanaraj)
hd- as feature request. 1.3? for comment 5


Evelyn's comment 2 should be a different bug. This one here is due to non-support for vcf import from MMS.
blocking-b2g: hd? → 1.3?

Comment 7

5 years ago
Hi, all,

Sorry for my very late reply.
I cannot reproduce this bug on V1.2 but I still can reproduce this bug on V1.1.0hd branch since we are not yet uplifted following patch to V1.1.0hd.
https://bugzilla.mozilla.org/show_bug.cgi?id=910164

* Test Build:
 - Gaia:     2a20910ea96efb538ec0c99ff25a540ed641f63f
 - Gecko:   
 - BuildID   20130923135853
 - Version   18.0

Many thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(whsu)
Resolution: --- → FIXED

Updated

5 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

5 years ago
hi,william

i am puzzled by what you said with Wilfred Mathanaraj's comment.

Do you mean that vcard in mms is supported in V1.2?
(Reporter)

Updated

5 years ago
Flags: needinfo?(whsu)

Comment 9

5 years ago
Hi, Lecky,

Sorry for my unclear information.
I mean this is a legacy bug and happened on V1.0.1 and V1.1.0.

We only uplifted this patch to V1.2. Detail information is shown below.
- https://bugzilla.mozilla.org/show_bug.cgi?id=910164
So, I still can reproduce this case on V1.1.0hd.

We still need stakeholder to decide whether we need to uplift this patch to V1.1.0hd.

By the way, this bug not only happened on MMS feature but also can reproduce on Bluetooth sharing.
If you send the VCard via Bluetooth, you also can reproduce this case.

Many thanks! ^^
Flags: needinfo?(whsu)
(Reporter)

Comment 10

5 years ago
hi,william,

i have checked bug 910164,

In my opinion,after uplift the patch of bug910164,the user will be able to import vcard to contacts,

right?

Then,i still do not understant what Wilfred Mathanaraj has commented:

" no vcard or vcal support from MMS in v1.2; this should be a feature request for v1.3 or beyond."

Comment 11

5 years ago
Hi, Lecky,

Sorry for my late reply.
Yes, if we uplift the patch (bug 910164), FxOS user can import Vcard to contact app.
But, the bug was marked as "Koi+". (A V1.2 patch)
We need to ask manager whether we need to change the flag to "hd+" and uplift it.

Regarding the information that Wilfred mentioned.
Wilfred might talk about a MMS feature. (MMS message can attach Vcard/Vcal, etc.?)

Thanks!
(Reporter)

Comment 12

5 years ago
hi,william

yes,mms message can attach vcard,and this issue is talking about when received vcard mms message,

the vcard information will be displayed as text,and we can not import it to contact app.

And i want to know the user case as you said:FxOS user can import Vcard to contact app.

Not in mms,then in which app?

Comment 13

5 years ago
Hi, Lecky,

Please see my update below.
Thanks!
--------------------------------------------------------------------------------------------
(In reply to lecky from comment #12)
> yes,mms message can attach vcard,and this issue is talking about when
> received vcard mms message,
You might say that MMS message of "Android" can attach Vcard.
But, I mean that MMS message of "FxOS" still cannot attach Vcard.
Wilfred mentioned we will add this feature to FxOS v1.3 or beyond.
This is the different case. ^^

> And i want to know the user case as you said:FxOS user can import Vcard to
> contact app.
> 
> Not in mms,then in which app?
The root cause of this bug is developer forgot to handle "HEADER" and "FOOTER" that caused FxOS cannot identify the Vcard.
After we add handling below, the bug is solved.

   vcardString += HEADER + vcard + '\n' + FOOTER;
(Reporter)

Comment 14

5 years ago
hi,william

Receiving mms with vcard and supporting import vcard to contact app will be supported in V1.2,

sending mms with vcard will be supported in V1.3 or above,

am i right?

Comment 15

5 years ago
Yes! You got it!
(Reporter)

Comment 16

5 years ago
hi,beatriz

can you accept the issue if it is not fixed on V1.1HD?
(Reporter)

Updated

5 years ago
Flags: needinfo?(brg)
(In reply to lecky from comment #16)
> hi,beatriz
> 
> can you accept the issue if it is not fixed on V1.1HD?
Yes we agree with Mozilla comment 9 (thanks William for the detail explanation in this bug)
Flags: needinfo?(brg)

Updated

5 years ago
See Also: → bug 925224
Already in 1.3, don't need to triage.
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.