Closed Bug 903252 Opened 7 years ago Closed 6 years ago

[Gaia] Video/image application: handover request to NFC app.

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 903253
1.3 Sprint 5 - 11/22

People

(Reporter: frlee, Assigned: johnhu)

References

Details

Gallery app. needs to be able to handover request to NFC app. while a NFC sharing video/image request has been made
Depends on: 894320
Blocks: 894320
No longer depends on: 894320
Hi Dale, are you available to handle this bug?
Flags: needinfo?(dale)
(repost) We arent picking up bugs individually these days, the feature requests go in the product backlog so we can properly estimate and prioritise them and will be picked up during sprints
Flags: needinfo?(dale)
blocking-b2g: --- → 1.3+
(In reply to Dale Harvey (:daleharvey) PTO - 28th Oct from comment #2)
> (repost) We arent picking up bugs individually these days, the feature
> requests go in the product backlog so we can properly estimate and
> prioritise them and will be picked up during sprints
Francis, can you please find a assignee from Gaia team?
Flags: needinfo?(frlee)
Depends on: 933093
Blocks: NFC-Gaia
hi John,

as we discussed in the NFC workweek, are you able to take this bug?
Flags: needinfo?(frlee)
Hi Francis,

Sure. I can handle it. But what's the scope and API of this bug?? Does this bug just put onpeerfound when Gallery and Video app enters detail view??
(In reply to John Hu [:johnhu] from comment #5)
> Hi Francis,
> 
> Sure. I can handle it. But what's the scope and API of this bug?? Does this
> bug just put onpeerfound when Gallery and Video app enters detail view??

Looks like it. ni from Francis, and also assign it to John Hu. 
John, please feel free to remove your name on the assignee if you're not handling this bug. Thank you.
Assignee: nobody → johu
Flags: needinfo?(frlee)
hi John, Kevin,

Onpeerfound is the indication tells Gallery/Video App that there's something to share. for details, i loop in Alive to comment.

hi Alive, 

please help to answer comment#5
Flags: needinfo?(frlee)
It seems better to finish this bug before sprint5. If you think it isn't reasonable, please update target milestone.
Target Milestone: --- → 1.3 Sprint 5 - 11/22
I will start work on this bug once bug 933093 landed because it needs "onpeerfound".
NFC is not a committed feature for 1.3, so this should not block the release.
blocking-b2g: 1.3+ → 1.3?
Moving this over to the Gallery app out of NFC, as the original comment targeted the Gallery app & this isn't related to the NFC core code base - it's Gaia changes.
Component: NFC → Gaia::Gallery
We can look into this for 1.4 - not committed feature for 1.3
blocking-b2g: 1.3? → 1.4?
The patch of this one and bug 903253 should be merged as one patch. One is for put onpeerfound callback and another is to implement that callback. I keep 903253 opening for tracking it.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 903253
blocking-b2g: 1.4? → ---
You need to log in before you can comment on or make changes to this bug.