[B2G][Helix][tongxiao]When change a contact "Zhabgfds" 's phone number for many times, it can not match correctly in call records.

RESOLVED DUPLICATE of bug 976990

Status

P2
normal
RESOLVED DUPLICATE of bug 976990
5 years ago
4 years ago

People

(Reporter: lecky.wanglei, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 788052 [details]
device.png

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; Tablet PC 2.0)

Steps to reproduce:

1.save "Zhabgfds" for its phone number is 588882844
2. make a call and update its number.
3. do up repeatly.


Actual results:

1.For forth time, the number is not match to "Zhabgfds" in call records.

Ref attachment.


Expected results:

1.Everytime the number can match to "Zhabgfds" in call records.
Hi Alberto, can you check also from the described STR for possibilities of this occurring?
Flags: needinfo?(alberto.pastor)
Keywords: qawanted
(Reporter)

Updated

5 years ago
blocking-b2g: --- → hd?
(Reporter)

Updated

5 years ago
Severity: normal → blocker
Priority: -- → P2

Comment 2

5 years ago
We have tried the STR for more than 10 calls but so far I am unable to repro this issue.

The build we are using is 20130904042205
Keywords: qawanted

Updated

5 years ago
Component: General → Gaia::Dialer
(Reporter)

Comment 3

5 years ago
I will do a second test and feedback soon.

Thanks!
(Reporter)

Comment 4

5 years ago
I think the problem is still exist.

Please see the scrrenshot.

Thanks!
(Reporter)

Comment 5

5 years ago
Created attachment 800543 [details]
screen shot

Comment 6

5 years ago
Hi, all,

Interesting. Now, I can use a easy way to reproduce this bug.
This bug easily happens on first time launched contact app.

* STR:
 1. Flash a new build to helix device or reset the helix device.
 2. Launch the contact app
 3. Add a contact
 4. Tap the added contact
 5. Tap the phone number to make a call
 6. Hang up
 7. Update the phone number
 8. Repeat Step5 ~ Step7 three times.
 9. Launch call log

* Test build:(Mozilla-b2g18_v1_1_0_hd-helix/2013-09-05-04-22-01)
  + Mercurial-Information
    - Gecko revision="838455b3eb13"
  + Git-information
    - Gaia revision="f0d08182afbf424b405b1d3864f557ef7c4f70c1"
  + Gecko version: 26.0a1


Attaching the screenshot.


--------- Change the status to "NEW" ---------
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

5 years ago
Created attachment 802150 [details]
Contact App - Incorrect call log
(Reporter)

Comment 8

5 years ago
Hi William:

   Are you wished to fix this issue in HD v1.1?

Thanks!
Flags: needinfo?(whsu)

Comment 9

5 years ago
Hi, Wayne,

Do you think we need to fix this problem on V1.1.0 branch?
Thank you.
Flags: needinfo?(whsu) → needinfo?(wchang)
Adding Francisco and Anthony.

QA can now consistently reproduce this bug, can you investigate?

Recommend not blocking as it requires the number to be changed many times. Please renom if you feel otherwise.
Severity: blocker → normal
blocking-b2g: hd? → koi?
Flags: needinfo?(wchang)
Flags: needinfo?(arcturus)
Flags: needinfo?(anthony)
(Reporter)

Comment 11

5 years ago
Hi :

   Are you wished to fix this issue in HD v1.1?

Thanks!
Flags: needinfo?(arcturus)
Flags: needinfo?(anthony)
Flags: needinfo?(alberto.pastor)
(Reporter)

Updated

5 years ago
Flags: needinfo?(wchang)
Lecky,
Please do not clear need information for other people.

William, can you kindly check this on v1.2 as well?
Flags: needinfo?(whsu)
Flags: needinfo?(wchang)
Flags: needinfo?(arcturus)
Flags: needinfo?(anthony)
Flags: needinfo?(alberto.pastor)
William: Does this reproduce on something else than a Helix?
Flags: needinfo?(anthony)
Flags: needinfo?(alberto.pastor)
QA Wanted for comment 13 - let's try testing this on something other than Helix (e.g. Buri).
Keywords: qawanted
Flags: needinfo?(arcturus) → needinfo?(francisco.jordano)
Sorry for the delay in the answer, I was on PTO.

I'm removing myself about the needinfo since this is a call log feature. Asking Fernando Jimenez if he knows more about this issue.

Thanks!
F.
Flags: needinfo?(francisco.jordano) → needinfo?(ferjmoreno)
Assignee: nobody → ferjmoreno
Flags: needinfo?(ferjmoreno)

Comment 16

5 years ago
Hi, all,

I can reproduce this bug on V1.2 branch.
I think other branches had the same problem and this was a legacy bug.

*Test Build:
 - Gaia:     a13c76f8d3c617ee57c302c103da04ed1a6298d1
 - Gecko:    http://hg.mozilla.org/releases/mozilla-aurora/rev/b34384409be6
 - BuildID   20130924004002
 - Version   26.0a2

Attaching the screenshot.
Flags: needinfo?(whsu)

Comment 17

5 years ago
Created attachment 809930 [details]
Call log - Buri

Comment 18

5 years ago
--------- Remove QAwanted ---------
Keywords: qawanted
triage: not a blocker for v1.2. minus
blocking-b2g: koi? → -
(Reporter)

Updated

5 years ago
Summary: [B2G][Helix][wangchao]When change a contact "Zhabgfds" 's phone number for many times, it can not match correctly in call records. → [B2G][Helix][tongxiao]When change a contact "Zhabgfds" 's phone number for many times, it can not match correctly in call records.
(Reporter)

Comment 20

5 years ago
 Hi :

   Are you wished to fix this issue in HD v1.1?

Thanks
Flags: needinfo?(wchang)
No, and not for v1.2 either.

Please read previous comments (comment 19.)

(In reply to lecky from comment #20)
>  Hi :
> 
>    Are you wished to fix this issue in HD v1.1?
> 
> Thanks
Flags: needinfo?(wchang)
Assignee: ferjmoreno → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 976990
You need to log in before you can comment on or make changes to this bug.