[Settings][HD] Text spacing incorrect in "Call Settings" and "Celluar & Data"

VERIFIED FIXED

Status

Firefox OS
Gaia::Settings
P1
normal
VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: epang, Assigned: ivanovpavel)

Tracking

unspecified
All
Other

Firefox Tracking Flags

(b2g18 affected, b2g-v1.1hd fixed)

Details

(Whiteboard: helix vsd, HD)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 788153 [details]
Settings - Spacing.png

Pavel, can you update the spacing so it's consistent with the other setting pages? See attached image. Thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 831429
We need to use this bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Created attachment 788206 [details]
patch for Gaia repo
Attachment #788206 - Flags: review?(felash)
Duplicate of this bug: 883302
Pavel: afaik this happens the same on non-hd and hd devices, right ?
Note that I filed duplicate bug 883302 some time ago and that it got leo-minused 2 months ago. Love this.
Pavel: reading bug 831429 comment 25, do you think there is a bug in Gecko ? or is Gecko working as expected here ?
Yep, does not depend on the resolution and I think it's not a Gecko bug. It's related with the l10n maybe... because if we have <a data-href="#call-voiceMailSettings" data-l10n-id="voiceMail">Voicemail</a> we have a problem ... but if we have <a data-href="#call-voiceMailSettings" data-l10n-id="voiceMail"> Voicemail </a> it works ... and when I try to make a test case everything work normal because I don't use l10n
nominating leo instead of hd because it does not depend on the resolution.

(I personally think this should not block)

Pavel, I don't see how l10n could change CSS rendering... Maybe you can try to do a testcase with the l10n library ?
blocking-b2g: hd? → leo?
Not blocking since we're not losing info on the screenshots, but flagging UX team so it's on their radar.
blocking-b2g: leo? → -
Flags: needinfo?(firefoxos-ux-bugzilla)
Comment on attachment 788206 [details]
patch for Gaia repo

r=me with the nit

simple fix, thanks !

But this still smells like a workaround, I still would like to know why we need this padding.
Attachment #788206 - Flags: review?(felash) → review+

Comment 12

5 years ago
Flagging Eric to advise on padding.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(epang)
Thanks Julien,
I will try to find out what happened there.
Landed in master:
https://github.com/mozilla-b2g/gaia/commit/18d8efc064cdd493f4f369e65e5abb761ac07d60

Landed in v1.1.0hd:
https://github.com/mozilla-b2g/gaia/commit/3523e8c7d95b6e183f302808d3bc9cd33d8833b6
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Pavel, why have you merged in 1.1.0hd ? This bug was not hd+...

I mean, it's not a big deal, and you know I'd like to see this in 1.1, but it was minused in comment 10...
(In reply to Julien Wajsberg [:julienw] from comment #15)
> Pavel, why have you merged in 1.1.0hd ? This bug was not hd+...
> 
> I mean, it's not a big deal, and you know I'd like to see this in 1.1, but
> it was minused in comment 10...

I just thinking that this is also for SD and HD. Eric asked Tim about landing HD bugs bug maybe I'm misunderstood. Sorry about this :(
(Reporter)

Comment 17

5 years ago
Hi Julien, i'm nomonating this as HD? since Pavel was correct to land in v1.1.0hd.  I should have nominated this earlier. Thanks!
blocking-b2g: - → hd?
Flags: needinfo?(epang)
Eric, you actually did, then I asked for leo because this is not a hd bug, and then it was minused.

As I said, I'd be happy to see this in both 1.1 branches, but we have processes...
(In reply to Julien Wajsberg [:julienw] from comment #18)
> Eric, you actually did, then I asked for leo because this is not a hd bug,
> and then it was minused.
> 
> As I said, I'd be happy to see this in both 1.1 branches, but we have
> processes...

Hey Julien,
I want to do it right, what I need to do now? (we have some other bugs who are in situation like this one and I want to prevent them for not correct landing of patches)
Just wait that hd+ and/or leo+ are set. hd+ should be to bugs specific to the hd devices, and leo+ for all 1.1 bugs. When you land it, you need to set the tracking flags too, for easy tracking ! usually you don't need to land it yourself, we have sheriff that do that according to the flags.

If it's minused, then just don't land it on the branches, it will be in 1.2.

As for this bug, I sincerely think it should be leo+ so that both branches are in sync, but you should wait for it...
status-b2g18: --- → affected
status-b2g-v1.1hd: --- → fixed
(Reporter)

Comment 21

5 years ago
(In reply to Julien Wajsberg [:julienw] from comment #20)
> Just wait that hd+ and/or leo+ are set. hd+ should be to bugs specific to
> the hd devices, and leo+ for all 1.1 bugs. When you land it, you need to set
> the tracking flags too, for easy tracking ! usually you don't need to land
> it yourself, we have sheriff that do that according to the flags.
> 
> If it's minused, then just don't land it on the branches, it will be in 1.2.
> 
> As for this bug, I sincerely think it should be leo+ so that both branches
> are in sync, but you should wait for it...

Pavel, I've added the tracking flag for the hd bugs we've opened so you don't have to worry about it :)

Comment 22

5 years ago
Thanks for your help!
Verified on the V1.1.0 HD build with latest helix base image(0805).
Marked as "Verified"+"Fixed"

* Test build:(Mozilla-b2g18_v1_1_0_hd-helix/2013-08-15-04-22-01)
  + Mercurial-Information
    - Gecko revision="bd0864949c0f"
  + Git-information
    - Gaia revision="d04d2d3969e4366fabafe9659f9b2705b7879ac2"

Attaching the screen shot
Status: RESOLVED → VERIFIED

Comment 23

5 years ago
Created attachment 791162 [details]
Text spacing
(Reporter)

Comment 24

5 years ago
(In reply to William Hsu [:whsu] from comment #23)
> Created attachment 791162 [details]
> Text spacing

looks great, thanks guys!
(Reporter)

Updated

5 years ago
Whiteboard: helix vsd → helix vsd, HD
Mass-modify - removal of no longer relevant blocking flags.

Updated

3 years ago
blocking-b2g: hd? → ---
You need to log in before you can comment on or make changes to this bug.