No new email notification, propably because of too many unread messages

RESOLVED DUPLICATE of bug 885220

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 885220
4 years ago
4 years ago

People

(Reporter: mr.burns, Unassigned)

Tracking

17 Branch
x86
Windows 8

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.95 Safari/537.36

Steps to reproduce:

I had between 600 and 1000 (I am not sure about the exact number) unread messages in my 4 email acounts.
The acounts were 2 IMAP acounts  (gmail) and 2 POP acounts (live.com & gmx.de).
IMAP Acounts were configured for IDLE mode. 

Everything worked well for about 2 years. 


Actual results:

From one day to another the new email notifications didnt show anymore. No sound played also.
New emails show up in the INBOX but no notifications. I send 10 test-emails but no luck. I even waited for 20 minutes but nothing happened (check for new emails was set to 10 mins).
After I ve read and deleted the unread messages everything worked fine again.


Expected results:

The new email popup should have shown and a sound should have played. If I previously received new mail on my IMAP acounts I got this about 2 seconds after the mail was sent.
If your "no new mail alert" occurs only when "new mail is detected via IDLE on Gmail IMAP account", is dup of bug 885220?

If different from bug 885220, what is essential difference of your problem from bug 885220?
(Reporter)

Comment 2

4 years ago
Bug 885220 happens on a newly created profile. I never had any trouble getting new mail notifications on my computer with gmail and IMAP before.
I received new mail alerts on this configuration for about 2 years without any problem.

After deleting the enormous number of unread mails I had in my inbox the new mail alert reapeared. So i think it is somehow linked to having too many unread mails in your inbox.
(In reply to mr.burns from comment #2)
> Bug 885220 happens on a newly created profile.

Have you read thru that bug and understoood? "newly created profile" in report means "problem is reproducible, even in newly created, clean and minimum profile"

> I never had any trouble getting new mail notifications on my computer with gmail and IMAP before.
> I received new mail alerts on this configuration for about 2 years without any problem.

Have you read thru that bug? CONDSTORE support by Gmail IMAP was done recently.

> After deleting the enormous number of unread mails I had in my inbox
> the new mail alert reapeared.
> So i think it is somehow linked to having too many unread mails in your inbox.

For which account(s) did you do "deleting the enormous number of unread mails I had in my inbox"?
(a) Two POP3 accounts, (b) Two Gmail IMAP accounts? (c) Both?

"New mail alert by Biff" is triggered by any of (i) New mails of POP3 account #1, (ii) New mails of POP3 account #2, (iii) New mails of GMail IMAP account #1,  (iv) New mails of GMail IMAP account #2.

"New mail alert triggered by which" is not shown in your environment?

Please note that bug 885220 is for "new mail alert by (iii) and (iv) is not shown".

If POP3 account, following can occur.
  Bug 640371 happens, then new mail is not downloaded any more.
  Because new mail is not downloaded, new mail alert won't occur on
  this POP3 account.
  Because "file size relevant problem in Compact folder" is bug 794303
  only now, if many mails are deleted and Inbox is compacted by
  auto-compact, new mail is downloaded again, then new mail alert is
  show again.
Please surely rule out such phenomenon.
(Reporter)

Comment 4

4 years ago
Thanks for your comment.

> Have you read thru that bug and understoood? "newly created profile" in report
> means "problem is reproducible, even in newly created, clean and minimum
> profile"

> Have you read thru that bug? CONDSTORE support by Gmail IMAP was done recently.

The bug appeared yesterday for the first time and after deleting the unread mails it disapeared again. I received about 20 emails since then (on the IMAP acounts) and all got me a popup and sound notification.

> For which account(s) did you do "deleting the enormous number of unread mails I
> had in my inbox"?
> (a) Two POP3 accounts, (b) Two Gmail IMAP accounts? (c) Both?

For all acounts. 

Acount 1 (IMAP) about 100 unread messages
Acount 2 (IMAP) about 100 unread messages
Acount 3 (POP3) about 100 unread messages
Acount 4 (POP3) about 600 unread messages

Comment 5

4 years ago
(In reply to WADA from comment #3)
> CONDSTORE support by Gmail IMAP was done recently.

Go into the Config Editor (that's in the Tools > Options > Advanced > General tab from the menu, or use the [≡] button to get to the Options dialog) and confirm the warning. In the search bar, enter "condstore" (without the quotes) and at least one entry should remain. Double-click on "mail.server.default.use_condstore" to set it to false and do so for any other ".use_condstore" entry you find.

Restart Thunderbird and see if it fixes the issue for the Gmail accounts.
(Reporter)

Comment 6

4 years ago
(In reply to rsx11m from comment #5)

> Double-click on "mail.server.default.use_condstore" to set it to false and do
> so for any other ".use_condstore" entry you find.

I restored my profile folder from a backup to reproduce the error and after doing as you suggested the email alerts reapeared.

One final question though:

Is there any disadvantage by not using condstore?

Sorry if this is a dumb question...

Thanks to all who helped solve this issue!

Comment 7

4 years ago
According to http://tools.ietf.org/html/rfc4551 its main function is to ensure that concurrent accesses of an IMAP account from multiple locations are properly synchronized. If it's not working correctly (and apparently it isn't) that feature isn't really helpful, and it shouldn't be relevant if you access your account only from one computer at a time (that's how I'd read it).

If the problem doesn't reoccur for any of your accounts, this bug report can be closed as a duplicate of bug 885220.
(Reporter)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 885220
You need to log in before you can comment on or make changes to this bug.