[Browser] [User Story] [Meta] Pull preloaded bookmarks into Top Sites screen

RESOLVED DUPLICATE of bug 1009633

Status

Firefox OS
Gaia::Browser
P3
normal
RESOLVED DUPLICATE of bug 1009633
5 years ago
4 years ago

People

(Reporter: kar, Unassigned)

Tracking

({feature, productwanted, uiwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: ux-priority1.3, ux-tracking)

(Reporter)

Description

5 years ago
If a partner has preloaded bookmarks, it is requested that the first 2 get pulled into the top two places on the Top Sites screen (as per Fennec functionality).

This will be dependent on:
- Ability to pin/unpin thumbnails on Top Sites (so the bookmarked thumbnails remain on-screen until a user has unpinned the thumbnail)
- Ability to pull the bookmark into the Top Sites screen
- Ability to bring over the dominant Favicon colour and the Favicon associated with the bookmark to use as the default image (until a user has visited the site and this will be replaced by a thumbnail of the site itself)

I expect we can reuse UI specs from Fennec but will need Ian/Francis to vet and attach.
(Reporter)

Updated

5 years ago
Flags: needinfo?(ibarlow)
Flags: needinfo?(fdjabri)
(Reporter)

Updated

5 years ago
Depends on: 903494
(Reporter)

Updated

5 years ago
Depends on: 903496
(Reporter)

Updated

5 years ago
Depends on: 903499
Keywords: productwanted

Comment 1

5 years ago
Addressed in Haida so removing ni? for Francis.
Flags: needinfo?(fdjabri)
Whiteboard: ux-priority1.3, ux-tracking

Updated

4 years ago
Flags: needinfo?(ibarlow)
I believe this functionality has been added for in 2.1 with the new browser start page.  Francis, can you confirm and close this bug if it has been?
Flags: needinfo?(fdjabri)
Yes, this has mostly been covered by Bug 1009633
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(fdjabri)
Resolution: --- → DUPLICATE
Duplicate of bug: 1009633
You need to log in before you can comment on or make changes to this bug.